View Issue Details

IDProjectCategoryView StatusLast Update
0002923SOGoWeb Calendarpublic2014-09-29 10:24
Reportersasha2002 Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version7 (Wheezy)
Fixed in Version2.2.9 
Summary0002923: Timezone problem when booking weekly
Description

If i try to create a weekly event and try to book room from 12:00 to 13:00 then i got an error :

The conflicting event is "EVENT NAME", and starts on 2014-10-31 11:30:00 +0200.

But this event start on 11:30 and end on 11:45.
As i understand here is one hour difference.
But for both user and Room, timezone is set Europe\Chisinau.

TagsNo tags attached.

Activities

francis

francis

2014-09-11 10:18

administrator   ~0007487

Which version of SOGo are you using?

sasha2002

sasha2002

2014-09-11 10:55

reporter   ~0007488

Version: 2.2.7-1

francis

francis

2014-09-11 11:15

administrator   ~0007489

Please try 2.2.8.

sasha2002

sasha2002

2014-09-12 03:33

reporter   ~0007491

Upgraded to the latest 2.2.8.

No luck. Problem persist.

sasha2002

sasha2002

2014-09-12 06:13

reporter   ~0007493

Found problem, timezone in sogo.conf does not have effect :
mysql> select NOW();
+---------------------+
| NOW() |
+---------------------+
| 2014-09-12 12:07:27 |
+---------------------+
1 row in set (0.03 sec)
mysql> Bye
root@ical:~# date
Fri Sep 12 13:07:32 EEST 2014

Please fix this terrible bug.
As i understand, if i set or not Timezone in sogo.conf mysql selects was not use this timezone setting.

ludovic

ludovic

2014-09-12 07:08

administrator   ~0007494

This is totally unrelated. Most likely, the problem is that SOGoAppointmentObject: - (NSException ) _handleResourcesConflicts: (NSArray ) theAttendees
forEvent: (iCalEvent *) theEvent

was not adjusted to handle the timezone offset based on the event's start date.

sasha2002

sasha2002

2014-09-15 09:23

reporter   ~0007507

Can you say any quick fix?

ludovic

ludovic

2014-09-15 09:26

administrator   ~0007508

Any quick fix!

sasha2002

sasha2002

2014-09-15 09:31

reporter   ~0007509

You made my day!

So, for the problem. How much time needs to fix it?
This is why i ask for quick fix.

sasha2002

sasha2002

2014-09-15 11:35

reporter   ~0007513

I can create new event on time selected if i do not select "Repeat". If i select any type of repeat i got an error! with hour -1. Also if i try to create new event after 12:00PM all is ok.

sasha2002

sasha2002

2014-09-29 06:08

reporter   ~0007564

Last edited: 2014-09-29 06:21

Upgraded to newly 2.2.9.

After i re-login, bug seems to be fixed.

Issue History

Date Modified Username Field Change
2014-09-11 09:36 sasha2002 New Issue
2014-09-11 10:18 francis Note Added: 0007487
2014-09-11 10:55 sasha2002 Note Added: 0007488
2014-09-11 11:15 francis Note Added: 0007489
2014-09-12 03:33 sasha2002 Note Added: 0007491
2014-09-12 06:13 sasha2002 Note Added: 0007493
2014-09-12 07:08 ludovic Note Added: 0007494
2014-09-15 09:23 sasha2002 Note Added: 0007507
2014-09-15 09:26 ludovic Note Added: 0007508
2014-09-15 09:31 sasha2002 Note Added: 0007509
2014-09-15 11:35 sasha2002 Note Added: 0007513
2014-09-29 06:08 sasha2002 Note Added: 0007564
2014-09-29 06:21 sasha2002 Note Edited: 0007564
2014-09-29 10:24 ludovic Status new => resolved
2014-09-29 10:24 ludovic Fixed in Version => 2.2.9
2014-09-29 10:24 ludovic Resolution open => fixed
2014-09-29 10:24 ludovic Assigned To => ludovic