View Issue Details

IDProjectCategoryView StatusLast Update
0002922SOGo Connectorwith external serverpublic2014-09-25 14:02
Reportermaestro_alubia Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformAMD64OSGentoo LinuxOS VersionRolling Release
Product Version24.0.4 
Fixed in Version31.0.0 
Summary0002922: sogo-connector: parallel make not working
Description

Hi,

i am currently packaging the SOGo Connector for Gentoo GNU/Linux (see bug report [1]). I am building it from source and noticed it does not work when using paralllel make like this:

make -j2

It gives the following output:

cat: MANIFEST: No such file or directory
cat: MANIFEST: No such file or directory
make[1]: Entering directory /home/fabian/workspace/Privat/sogo-connector.tb24' make[1]: warning: jobserver unavailable: using -j1. Add+' to parent make rule.
cat: MANIFEST: No such file or directory
Generating sogo-connector-24.0.6-e43efe3223.xpi...
make[1]: [sogo-connector-24.0.6-e43efe3223.xpi] Error 12
make[1]: Leaving directory `/home/fabian/workspace/Privat/sogo-connector.tb24'
make:
[rest] Error 2
make: *** Waiting for unfinished jobs....

Using make -j1 works fine, though. Although this is not a big problem because the sourcecode is really small and parallel jobs do not give great benefit here, Gentoo policy requires that these kind of issues are reported upstream.

Steps To Reproduce

Build SOGo Connector with make -j<n> where n is >1.

Additional Information

Using GNU Make 3.82

TagsNo tags attached.

Activities

ludovic

ludovic

2014-09-25 14:02

administrator   ~0007550

Merged

https://github.com/inverse-inc/sogo-connector.tb24/commit/86dc9f853481357b5ac0f0cedb08a7fbd1808636

I don't know if we'll release a v24.0.7 with just that change.. but it'll also be part of v31.

Issue History

Date Modified Username Field Change
2014-09-11 03:49 maestro_alubia New Issue
2014-09-25 14:02 ludovic Note Added: 0007550
2014-09-25 14:02 ludovic Status new => resolved
2014-09-25 14:02 ludovic Fixed in Version => 31.0.0
2014-09-25 14:02 ludovic Resolution open => fixed
2014-09-25 14:02 ludovic Assigned To => ludovic