View Issue Details

IDProjectCategoryView StatusLast Update
0002889SOGoBackend Calendarpublic2014-09-24 12:03
ReporterGunnar Weissmann Assigned Toludovic  
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version6 (Squeeze)
Product Version2.2.7 
Target Version2.2.9Fixed in Version2.2.9 
Summary0002889: Problem with repeating events with a time change (e.g. standard time after 26. Oktober 2014)
Description

At first we create an event "TimeChange01" that runs without end (screenshot: event_create.png & event_create_without_end.png), every week on wednesday from 9:00 until 10:00 with a ressource room.
After that we create an event "TimeChange02" from 10:00 until 11:00 every week with the same ressource.
We get the warning, that the resource is booked more than one time which is not true as you can see in the screenshot (event_view_29_10_14.png).
We added two more screenshots (event_availability_start.png & event_availability_29_10_14.png) that shows the availability at the start date and the 29th of october. At the 29th of october you doesn't see the any availability which is another bug, because when you change the week and goes back to the 29th there are other events that doesn't exists on that date (event_availability_after_after_switching_back.png).

We think that this is a bug in calculation of the availability of attendees.

The problem exists on all clients.

Thank you,

Gunnar Weissmann

TagsNo tags attached.

Relationships

duplicate of 0001240 resolvedludovic Time shifted because of Daylight Saving Time in Free/Busy 

Activities

Gunnar Weissmann

Gunnar Weissmann

2014-08-11 07:53

reporter  

event_create.png (42,731 bytes)   
event_create.png (42,731 bytes)   
Gunnar Weissmann

Gunnar Weissmann

2014-08-11 07:53

reporter  

event_create_without_end.png (26,507 bytes)   
event_create_without_end.png (26,507 bytes)   
Gunnar Weissmann

Gunnar Weissmann

2014-08-11 07:56

reporter  

warning.png (129,002 bytes)   
warning.png (129,002 bytes)   
Gunnar Weissmann

Gunnar Weissmann

2014-08-11 07:56

reporter  

event_availability_start.png (30,702 bytes)   
event_availability_start.png (30,702 bytes)   
Gunnar Weissmann

Gunnar Weissmann

2014-08-11 07:57

reporter  

event_availability_29_10_14.png (30,708 bytes)   
event_availability_29_10_14.png (30,708 bytes)   
Gunnar Weissmann

Gunnar Weissmann

2014-08-11 07:57

reporter  

Gunnar Weissmann

Gunnar Weissmann

2014-08-11 07:58

reporter  

event_view_29_10_14.png (28,234 bytes)   
event_view_29_10_14.png (28,234 bytes)   
Gunnar Weissmann

Gunnar Weissmann

2014-08-15 08:38

reporter   ~0007409

Last edited: 2014-08-15 08:53

View 2 revisions

It seems that after the 26th of October (Time Zone Europe/Berlin) the available times are shifted one hour in the future every week when you show it in the "editAttendees" page.

This problem is very serious for us; can you expect how long it would take to fix this issue?

Thank you.

ludovic

ludovic

2014-08-15 08:39

administrator   ~0007410

We aim to fix the bug in the next 2-3 weeks, for the v2.2.8 release.

Gunnar Weissmann

Gunnar Weissmann

2014-08-15 09:22

reporter   ~0007411

That would be great!

Thank you.

Gunnar Weissmann

Gunnar Weissmann

2014-09-23 06:29

reporter   ~0007531

You resolved the duplicated bug http://www.sogo.nu/bugs/view.php?id=1240.

We updated to SOGo Version 2.2.8 and tested again.

The problem still exists in our case when we create an event with a weekly repetition.

We use weekly events with resource rooms that accept the invitations automatically when they doesn't have more than one event at the same time.

On weekly events the resource is still not available after the 25th of october although it is available. The webinterface shows the warning, that the event is booked more than one time what it's not correct.

We suggest that depends on the same Problem like mentioned initially.

On single events we are able to create an event after the 25th of october with the resource.

Is there anything we can do to assist you to fix the problem? We can not migrate to SoGo as long as this problem exists.

Thank you.

G. Weissmann

ludovic

ludovic

2014-09-23 08:36

administrator   ~0007532

The problem is present with resource only, not with 'normal attendees'.

We realized this shortly after v2.2.8 was released and it'll be fixed in v2.2.9.

Gunnar Weissmann

Gunnar Weissmann

2014-09-23 08:59

reporter   ~0007533

THX for the info.

Gunnar Weissmann

Gunnar Weissmann

2014-09-24 05:41

reporter   ~0007539

Can you expect a release date for v2.2.9? Thanks.

ludovic

ludovic

2014-09-24 12:03

administrator   ~0007541

Fixed with this commit: https://github.com/inverse-inc/sogo/commit/1c60ab2337815b73ab651ac39f5465944c10e479

v2.2.9 will be released this week.

Issue History

Date Modified Username Field Change
2014-08-11 07:53 Gunnar Weissmann New Issue
2014-08-11 07:53 Gunnar Weissmann File Added: event_create.png
2014-08-11 07:53 Gunnar Weissmann File Added: event_create_without_end.png
2014-08-11 07:56 Gunnar Weissmann File Added: warning.png
2014-08-11 07:56 Gunnar Weissmann File Added: event_availability_start.png
2014-08-11 07:57 Gunnar Weissmann File Added: event_availability_29_10_14.png
2014-08-11 07:57 Gunnar Weissmann File Added: event_availability_after_after_switching_back.png
2014-08-11 07:58 Gunnar Weissmann File Added: event_view_29_10_14.png
2014-08-11 09:46 ludovic Relationship added duplicate of 0001240
2014-08-15 08:38 Gunnar Weissmann Note Added: 0007409
2014-08-15 08:39 ludovic Note Added: 0007410
2014-08-15 08:53 Gunnar Weissmann Note Edited: 0007409 View Revisions
2014-08-15 09:22 Gunnar Weissmann Note Added: 0007411
2014-09-23 06:29 Gunnar Weissmann Note Added: 0007531
2014-09-23 08:36 ludovic Note Added: 0007532
2014-09-23 08:36 ludovic Target Version => 2.2.9
2014-09-23 08:59 Gunnar Weissmann Note Added: 0007533
2014-09-24 05:41 Gunnar Weissmann Note Added: 0007539
2014-09-24 12:03 ludovic Note Added: 0007541
2014-09-24 12:03 ludovic Status new => resolved
2014-09-24 12:03 ludovic Fixed in Version => 2.2.9
2014-09-24 12:03 ludovic Resolution open => fixed
2014-09-24 12:03 ludovic Assigned To => ludovic