View Issue Details

IDProjectCategoryView StatusLast Update
0002888SOGo ConnectorBackend Address Bookpublic2014-09-26 11:22
Reporterkotta Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version24.0.4 
Fixed in Version31.0.0 
Summary0002888: Cannot add remote address book
Description

Sogo connector for thunderbird cause the following error when i try add new remote addressbook.

XML feldolgozási hiba: nem definiált entitás
Hely: chrome://sogo-connector/content/addressbook/preferences.addressbook.groupdav.xul

  1. sor, 13. oszlop: <checkbox id="periodicSync" label="&groupdavPeriodicSync.label;" oncommand="onUpdateCheck();onShowRestart()" />
    ------------^
Steps To Reproduce

1., Install thunderbird hungarian language.
2., Install Sogo connector
3., try add new remote addressbook

Additional Information

I try it MACOSX mavericks, Windows XP hungarian, Windows 7 64 bit hungarian and windows 8 64 bit hungarian.

The problem can reproduced all OS.

TagsNo tags attached.

Activities

Christian Mack

Christian Mack

2014-08-11 03:37

developer   ~0007402

Which Thunderbird version?
Which Lightning version?

kotta

kotta

2014-08-11 03:42

reporter   ~0007403

thunderbird 24.6.0
lightning 2.6.6
sogo connector 24.0.6

makiarc

makiarc

2014-08-22 10:39

reporter   ~0007424

Hi Kotta!

Please try this: (On my thunderbird it's works)
0 step

  • remove any sogo extension
    1 step
  • install quick local switcher thunderbird extension
    2 step
  • tools menu -> quick local switcher -> set en_US
    3 step
  • reinstall sogo extension
    4 step
  • add new remote calendar :-)
kotta

kotta

2014-08-22 11:54

reporter   ~0007425

Hi makiarc!

This problem come when i try to add ne remote addressbook, the new remote calendar adding (your 4th step) working well without "quick locale switcher".

Anyway, thank you for your tip, i tried it but not lucky.
Tested on MacOSX and Windows XP, but i think the windows 7 its the same.

Interesting that the contacts window not have localisation because the "quick locale switcher" indicator not shown this window.

kallo

kallo

2014-09-04 10:26

reporter   ~0007471

Hi!

I have the same issue, with hungarian version of thunderbird(I tried 24.0,24.6,24.2,31).
With Englis(US) version work like a charm.

ludovic

ludovic

2014-09-25 14:24

administrator   ~0007554

The Hungarian translation is broken - please fix it and send us a patch.

It's missing all groupdavPeriodicSync labels. For example:

chrome/locale/en-US/sogo-connector/addressbook/pref-directory-add.dtd:<!ENTITY groupdavPeriodicSync.label "Periodic sync" >
chrome/locale/en-US/sogo-connector/addressbook/pref-directory-add.dtd:<!ENTITY groupdavPeriodicSync5m.label "5 min" >
chrome/locale/en-US/sogo-connector/addressbook/pref-directory-add.dtd:<!ENTITY groupdavPeriodicSync15m.label "15 min" >
chrome/locale/en-US/sogo-connector/addressbook/pref-directory-add.dtd:<!ENTITY groupdavPeriodicSync1h.label "1 h" >
chrome/locale/en-US/sogo-connector/addressbook/pref-directory-add.dtd:<!ENTITY groupdavPeriodicSync2h.label "2 h" >

Look at chrome/locale/hu-HU/sogo-connector/ for files to fix.

kotta

kotta

2014-09-25 16:27

reporter   ~0007557

XML feldolgozási hiba: nem definiált entitás
Hely:
chrome://sogo-connector/content/addressbook/preferences.addressbook.groupdav.xul

  1. sor, 13. oszlop: <checkbox id="periodicSync"
    label="&groupdavPeriodicSync.label;" oncommand="onUpdateCheck();onShowRestart()"
    />
    ------------^

Translated:

XML parse error: not definied entity
Place:
chrome://sogo-connector/content/addressbook/preferences.addressbook.groupdav.xul

  1. row, 13 columb:
    <checkbox id="periodicSync"
    label="&groupdavPeriodicSync.label;" oncommand="onUpdateCheck();onShowRestart()"
    />
    ------------^
ludovic

ludovic

2014-09-25 19:49

administrator   ~0007558

This is exactly what I said. Translations are missing. Add them or I'll simply drop the Hungarian translation.

kotta

kotta

2014-09-26 03:34

reporter  

pref-directory-add.dtd (Attachment missing)
kotta

kotta

2014-09-26 03:35

reporter   ~0007559

I attached the translated file.

ludovic

ludovic

2014-09-26 11:22

administrator   ~0007560

Fixed for TB24 and 31.

The commit for TB 24 is here:

https://github.com/inverse-inc/sogo-connector.tb24/commit/f1daebe3b515397e428e29182a4c513e7388f321

For 31:

https://github.com/inverse-inc/sogo-connector.tb31/commit/14351d19618f4ae8e46386ab016a7ad9f2e4a67a

Issue History

Date Modified Username Field Change
2014-08-08 09:24 kotta New Issue
2014-08-11 03:37 Christian Mack Note Added: 0007402
2014-08-11 03:42 kotta Note Added: 0007403
2014-08-22 10:39 makiarc Note Added: 0007424
2014-08-22 11:54 kotta Note Added: 0007425
2014-09-04 10:26 kallo Note Added: 0007471
2014-09-25 14:24 ludovic Note Added: 0007554
2014-09-25 14:24 ludovic Project SOGo Integrator => SOGo Connector
2014-09-25 16:27 kotta Note Added: 0007557
2014-09-25 19:49 ludovic Note Added: 0007558
2014-09-26 03:34 kotta File Added: pref-directory-add.dtd
2014-09-26 03:35 kotta Note Added: 0007559
2014-09-26 11:22 ludovic Note Added: 0007560
2014-09-26 11:22 ludovic Status new => resolved
2014-09-26 11:22 ludovic Fixed in Version => 31.0.0
2014-09-26 11:22 ludovic Resolution open => fixed
2014-09-26 11:22 ludovic Assigned To => ludovic