View Issue Details

IDProjectCategoryView StatusLast Update
0002878SOGoApple Calendar (Mac OS X)public2014-09-17 11:36
ReporterGunnar Weissmann Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version7 (Wheezy)
Product Version2.2.7 
Target Version2.2.9Fixed in Version2.2.9 
Summary0002878: No busy/free status in iCal 7.0
Description

There is no busy/free status in iCal 7.0 in opposite to iCal 6.0. With iCal Server there is a busy/free status in iCal 7.0 as well, so this option isn't removed in iCal 7.0.

We added screen-shots to show the missing option and the comparison to iCal 6.

Is there a way to add this option?

Additional Information
  • nginx 1.6 as reverse proxy
TagsNo tags attached.

Activities

Gunnar Weissmann

Gunnar Weissmann

2014-08-04 09:58

reporter  

iCal7_with_free_busy.png (100,307 bytes)   
iCal7_with_free_busy.png (100,307 bytes)   
Gunnar Weissmann

Gunnar Weissmann

2014-08-04 09:59

reporter  

iCal7_without_free_busy.png (50,591 bytes)   
iCal7_without_free_busy.png (50,591 bytes)   
Gunnar Weissmann

Gunnar Weissmann

2014-08-04 09:59

reporter  

iCal6_with_free_busy.png (46,062 bytes)   
iCal6_with_free_busy.png (46,062 bytes)   
Christian Mack

Christian Mack

2014-08-05 08:53

developer   ~0007385

The shown appointment is an all day event.
I assume you have set:
SOGoiPhoneForceAllDayTransparency = YES;

With this all "All Day" events will be set to free automatically.

Gunnar Weissmann

Gunnar Weissmann

2014-08-05 09:25

reporter   ~0007386

We didn't set the option: SOGoiPhoneForceAllDayTransparency = YES;

The event is not an all-day event.

We are missing the option "Show as" when we create an event with iCal 7.0/sogo server as you can see in the "iCal7_without_free_busy.png"screenshot.

We expect that this is a bug/incompatibility because it's working in iCal 6.0.

Christian Mack

Christian Mack

2014-08-06 03:13

developer   ~0007394

Sorry, my fault.
(Was sure I had seen the "All day" flag :-( )

Do you get any special error messages in SOGo while synchronising with iCal 7?

ludovic

ludovic

2014-09-17 11:36

administrator   ~0007518

https://github.com/inverse-inc/sogo/commit/a4ab2942e89c74915725aa51da4c25b2cc5b6049

Issue History

Date Modified Username Field Change
2014-08-04 09:58 Gunnar Weissmann New Issue
2014-08-04 09:58 Gunnar Weissmann File Added: iCal7_with_free_busy.png
2014-08-04 09:59 Gunnar Weissmann File Added: iCal7_without_free_busy.png
2014-08-04 09:59 Gunnar Weissmann File Added: iCal6_with_free_busy.png
2014-08-05 08:53 Christian Mack Note Added: 0007385
2014-08-05 09:25 Gunnar Weissmann Note Added: 0007386
2014-08-06 03:13 Christian Mack Note Added: 0007394
2014-09-12 11:21 ludovic Target Version => 2.2.9
2014-09-17 11:36 ludovic Note Added: 0007518
2014-09-17 11:36 ludovic Status new => resolved
2014-09-17 11:36 ludovic Fixed in Version => 2.2.9
2014-09-17 11:36 ludovic Resolution open => fixed
2014-09-17 11:36 ludovic Assigned To => ludovic
2014-09-26 14:08 ludovic Category Apple iCal.app => Apple Calendar (Mac OS X)