View Issue Details

IDProjectCategoryView StatusLast Update
0002849SOGoActiveSyncpublic2015-10-14 09:24
Reportertfu Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.2.6 
Fixed in Version2.3.3 
Summary0002849: possibile syncCache inconsistencies
Description

Due to unstable connections or in case the user stops the sync on his devices inconsistencies between syncCache and the client could occur.

Due to that it e.g. could happen that mails deleted on server are never removed on client.

Steps To Reproduce

->Set SOGoMaximumSyncInterval=30 / SOGoInternalSyncInterval=5 (these parameter ->are actually not required to reproduce but they allow enough time to demo the ->issue)

->Start a sync on mobile (no push/ping)-> syncKey = 4711
...
Sleeping 5 seconds while detecting changes...
Sleeping 5 seconds while detecting changes...
...
->cancel the sync on mobile -> this doesn't stop the active request on server
...
Sleeping 5 seconds while detecting changes...
Sleeping 5 seconds while detecting changes...
-> delete a mail on server
Change detected, we push the content.
-> the cache is now updated and the deleted mail is removed from syncCache
-> the response can never reach the mobile since the sync-operation was canceled

===
Now issue another sync on mobile -> the client send again syncKey=4711
Since the syncCache entry was already deleted no delete requested will be included into the response.

TagsNo tags attached.

Issue History

Date Modified Username Field Change
2014-07-09 07:23 tfu New Issue
2015-10-14 09:24 ludovic Note Added: 0008995
2015-10-14 09:24 ludovic Status new => resolved
2015-10-14 09:24 ludovic Fixed in Version => 2.3.3
2015-10-14 09:24 ludovic Resolution open => fixed
2015-10-14 09:24 ludovic Assigned To => ludovic