View Issue Details

IDProjectCategoryView StatusLast Update
0002818SOGoWeb Mailpublic2014-07-09 11:23
ReporterAlbertShih Assigned Tofrancis  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformNo depend 
Product Version2.2.5 
Fixed in Version2.2.7 
Summary0002818: Unable to close compose windows when the mail containt a attachment and when thread view is enable
Description

When the option
Sort messages by threads
is enable, and if we :
answer to a message with a attachment and if the answer got a attachment
forward a mail with a attachment and the forward is make as attachment
the compose windows crash, the mail is sent, but it's impossible to close the windows and all button on the windows is dead.

Steps To Reproduce

1/ Activate the
Sort messages by threads
in Preferences/mail options
2/ find a message with a attachment
3/ reply to that message,
4/ attach a file on that message
5/ click on the send button.

1/ Activate the
Sort messages by threads
and
Forward messages: As attachment
2/ find a message with a attachment
3/ forward this message to somebody
4/ click on the send button

TagsNo tags attached.

Activities

follc

follc

2014-06-30 10:16

reporter   ~0007260

I have the same bug, very annoying...

ludovic

ludovic

2014-06-30 10:23

administrator   ~0007261

I can't reproduce the bug with the current nightly builds.

Can you test them to make sure it's gone?

We're just about to do a release of v2.2.6 so they are safe to use.

follc

follc

2014-06-30 10:37

reporter   ~0007262

I've just tried with the nighty on a wheezy and the problem is the same...

ludovic

ludovic

2014-06-30 10:38

administrator   ~0007263

With the same procedures above?

Which browser do you use?

follc

follc

2014-06-30 10:53

reporter   ~0007264

Yes, same procedure.

If I send a new message with attachement it works well.
If I reply to a message and add a attachement:
-it works if messages aren't group by threads.
-if message are group by threads when I try to send the message nothing happen (but the mail is sent).

ludovic

ludovic

2014-06-30 10:54

administrator   ~0007265

Which browser do you use?

follc

follc

2014-06-30 11:01

reporter   ~0007266

Safari 7.0.4 and Chrome 36.0.1985.97 beta on Mac OS X

AlbertShih

AlbertShih

2014-06-30 11:04

reporter   ~0007267

The bug is present with
Firefox-30.0 (FreeBSD 10)
Firefox-30.0 (Windows-2008 server)
Firefox (latest on Ubuntu latest version)
Chrome (FreeBSD 10) 35.0.1916.153
Chrome (Windows-2008 server)
Opera 12.16 (FreeBSD 10)

well in fact the bug is present on all browser and OS I have access

Regards.

JAS

ludovic

ludovic

2014-06-30 11:24

administrator   ~0007268

Works for me.

Have a look at your Javascript console and paste any errors here.

follc

follc

2014-06-30 11:31

reporter   ~0007269

Don't have any error but I'm not specialist about javascript debugging...

AlbertShih

AlbertShih

2014-06-30 11:47

reporter   ~0007270

Before I post this bug report I've already try to find some message, but with Firebug in Firefox I was unable to find any message.

I try to compare the log between with bug (thread enable) and without bug (thread disable) and was unable to find any difference because.

Regards

francis

francis

2014-07-09 11:23

administrator   ~0007304

Fixed.

See https://github.com/inverse-inc/sogo/commit/44d0cb5c0d57de6548148ea204f49a5d697e8358

Issue History

Date Modified Username Field Change
2014-06-17 02:36 AlbertShih New Issue
2014-06-30 10:16 follc Note Added: 0007260
2014-06-30 10:23 ludovic Note Added: 0007261
2014-06-30 10:37 follc Note Added: 0007262
2014-06-30 10:38 ludovic Note Added: 0007263
2014-06-30 10:53 follc Note Added: 0007264
2014-06-30 10:54 ludovic Note Added: 0007265
2014-06-30 11:01 follc Note Added: 0007266
2014-06-30 11:04 AlbertShih Note Added: 0007267
2014-06-30 11:24 ludovic Note Added: 0007268
2014-06-30 11:31 follc Note Added: 0007269
2014-06-30 11:47 AlbertShih Note Added: 0007270
2014-07-09 11:23 francis Note Added: 0007304
2014-07-09 11:23 francis Status new => resolved
2014-07-09 11:23 francis Fixed in Version => 2.2.7
2014-07-09 11:23 francis Resolution open => fixed
2014-07-09 11:23 francis Assigned To => francis