View Issue Details

IDProjectCategoryView StatusLast Update
0000278SOGoWeb Preferencespublic2011-11-16 13:48
Reportertolivier Assigned Toludovic  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Versionnightly v2 
Target Version1.3.10Fixed in Version1.3.10 
Summary0000278: daemon crash if imap is unavailable
Description

sogo crash if i modify my mail settings in preference when imap server is not available.

Additional Information

127.0.0.1 - - [10/Dec/2009:14:33:36 GMT] "GET /SOGo/so/toto/preferences HTTP/1.1" 200 12783/0 0.119 50163 74% 3M
EXCEPTION: <NGCouldNotConnectException: 0xa5c3328> NAME:NGCouldNotConnectException REASON:Could not connect to address <0x0xa5c7f40[NGInternetSocketAddress]: host=imap.univ-lille1.fr port=2000>: connection refused INFO:(nil)
<0x0xa0f1808[WOWatchDog]> received SIGCHLD: 31585
<0x0xa0f1808[WOWatchDog]> (terminated due to signal 6)
<0x0xa0f1808[WOWatchDog]> child spawned with pid 31588
SNS support disabled.
.....

TagsNo tags attached.

Activities

tolivier

tolivier

2010-01-20 09:36

reporter   ~0000464

Last edited: 2010-01-20 09:37

Bonjour Ludovic,

J'ai remarqué que cette erreur apparait uniquement quand j'active SOGoForwardEnabled ou SOGoVacationEnabled car le démon ManageSieve n'est pas activé.

Serait-il possible de faire une petite vérification avant de faire cette connexion vers le serveur? - pour éviter le crash -

Merci.

Thomas.

ludovic

ludovic

2011-11-16 13:48

administrator   ~0003021

http://mtn.inverse.ca/revision/diff/92cceaf860bbf56d983063471093858a3871ec23/with/e38c570559610854b85c2c517053417779a76964

Issue History

Date Modified Username Field Change
2009-12-10 08:45 tolivier New Issue
2010-01-20 09:36 tolivier Note Added: 0000464
2010-01-20 09:37 tolivier Note Edited: 0000464
2011-11-07 16:07 ludovic Status new => assigned
2011-11-07 16:07 ludovic Assigned To => ludovic
2011-11-07 16:07 ludovic Target Version => 1.3.10
2011-11-16 13:48 ludovic Note Added: 0003021
2011-11-16 13:48 ludovic Status assigned => closed
2011-11-16 13:48 ludovic Resolution open => fixed
2011-11-16 13:48 ludovic Fixed in Version => 1.3.10