View Issue Details

IDProjectCategoryView StatusLast Update
0002767SOGoBackend Calendarpublic2014-07-29 10:37
ReporterJens Erat Assigned Toludovic  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Fixed in Version2.2.7 
Summary0002767: Users should be able to prevent being invited to appointments
Description

Some of our users request being able to forbid all invitations to appointments, as only their secretariat should be able to make appointments. This includes:

  • Not being able to select those users when creating meetings with appointments, with a meaningful error message
  • If an invitation arrives anyway (eg. by external users) it should be declined automatically

A whitelist of allowed event organizers would be nice to have in addition.

Additional Information

Also other systems like Zimbra have a similar option, which is gladly used by some users in management drowning in appointments and events, which should be handled by their secretariat.

TagsNo tags attached.

Activities

ludovic

ludovic

2014-05-23 15:19

administrator   ~0007113

That part "- If an invitation arrives anyway (eg. by external users) it should be declined automatically" is not possible, since SOGo doesn't have the user's password and isn't informed when a mail is delivered in the user's mailbox.

Christian Mack

Christian Mack

2014-05-26 03:41

developer   ~0007115

Could this part be done with a sieve filter?
(At least for those who activated sieve filters via SOGo.)

ludovic

ludovic

2014-05-26 11:01

administrator   ~0007121

Not really, since the Sieve server would need to generate a full IMIP decline response.

ludovic

ludovic

2014-07-21 14:21

administrator   ~0007339

https://github.com/inverse-inc/sogo/commit/f3ded6ce2a908696e618aa088359e88c9d7f3083

Christian Mack

Christian Mack

2014-07-25 11:56

developer   ~0007355

A) Is it possible to get the forbidden message while in the invitation window instead of while saving the event?

B) Could you rephrase the message, in order to make it clear, that inviting is forbidden for these users?
(One of our test users thought: Inviting didn't succeed because of an error in the SOGo server.)
Perhaps something like:
"Inviting of the following persons is forbidden for you:"

ludovic

ludovic

2014-07-25 12:37

administrator   ~0007357

For A, we do it this way to match the Lightning or any other DAV client behavior. The error will append over a PUT in DAV, not during the check of the freebusy. And the PUT is done when saving the event.

ludovic

ludovic

2014-07-29 10:37

administrator   ~0007362

Improved text message:

https://github.com/inverse-inc/sogo/commit/94f3246658c151b55ca86404c607fe29de7b94b1

Issue History

Date Modified Username Field Change
2014-05-16 07:23 Jens Erat New Issue
2014-05-23 15:19 ludovic Note Added: 0007113
2014-05-26 03:41 Christian Mack Note Added: 0007115
2014-05-26 11:01 ludovic Note Added: 0007121
2014-07-21 14:21 ludovic Note Added: 0007339
2014-07-21 14:21 ludovic Status new => resolved
2014-07-21 14:21 ludovic Fixed in Version => 2.2.7
2014-07-21 14:21 ludovic Resolution open => fixed
2014-07-21 14:21 ludovic Assigned To => ludovic
2014-07-25 11:56 Christian Mack Note Added: 0007355
2014-07-25 11:56 Christian Mack Status resolved => feedback
2014-07-25 11:56 Christian Mack Resolution fixed => reopened
2014-07-25 12:37 ludovic Note Added: 0007357
2014-07-29 10:37 ludovic Note Added: 0007362
2014-07-29 10:37 ludovic Status feedback => closed
2014-07-29 10:37 ludovic Resolution reopened => fixed