View Issue Details

IDProjectCategoryView StatusLast Update
0002759SOGoWeb Calendarpublic2014-08-27 16:13
ReporterJens Erat Assigned Toludovic  
PriorityhighSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.2.3 
Target Version3.0.0Fixed in Version2.2.7 
Summary0002759: Events and tasks cannot be moved to other calendars using drag&drop
Description

Events and tasks cannot be moved to other calendars using drag&drop. Some of our users archive their solved tasks into yearly task archives (eg., "Finished Tasks 2013", Finished Taks 2014", ...).

With SOGo, moving them is a very long and annoying job (open the task, changing the calendar, saving it, closing it). Just dragging them would make this much easier. Applies to both task and event entries in the calendar list view.

Steps To Reproduce
  1. Open calendar view
  2. Select task(s) to move
  3. Dragging them onto a new calendar in the calendar view on the left is not supported
TagsNo tags attached.

Activities

ludovic

ludovic

2014-07-21 14:22

administrator   ~0007340

https://github.com/inverse-inc/sogo/commit/11920f592c8a144e80b4be8b2f8b2b586fe4a33e

Christian Mack

Christian Mack

2014-07-24 07:46

developer   ~0007344

Tasks are not movable per drag and drop.

Also you only can use multi-column view for drag and drop of events into other calendars.
This should work independant of the selected view.

ludovic

ludovic

2014-07-24 08:04

administrator   ~0007345

Ok for tasks.

It works with all views for me.

Jens Erat

Jens Erat

2014-07-24 08:18

reporter   ~0007346

Using Iceweasel 30 (probably also Firefox) I cannot move any events from the day/week/month/multicolumn views to other calendars (it works from the event list though, as well as between columns in the multi column view).

In Chrome, moving events works fine. What browsers did you test against?

ludovic

ludovic

2014-07-24 14:05

administrator   ~0007347

Both issues should be fixed.

Jens Erat

Jens Erat

2014-08-01 05:51

reporter   ~0007375

Last edited: 2014-08-01 05:57

Problems still exist in Firefox/Iceweasel 30.

  1. Dragging events mostly works, but when trying to drop them, the calendar does not always accept the dragged item. This is visible by the highlighting of the calendar item disappearing. Moving on the item or out of it (to the next calendar and back) helps. If the cursor position changes a lot (touchpad) drag and drop is pretty much unusable. This is not a problem for mail, only appears when dragging events.

  2. Dragging tasks is still not possible in Firefox/Iceweasel 30. Works fine in Chrome, though. We did note though that when trying to drag a task item (which does not work, right arrow in screenshot) some icon appears in the month overview in the left bar (left arrow). Only disappears when reloading the tab.

Jens Erat

Jens Erat

2014-08-01 05:57

reporter  

Auswahl_001.png (26,690 bytes)   
Auswahl_001.png (26,690 bytes)   
francis

francis

2014-08-01 12:59

administrator   ~0007378

Can you try this patch?

https://github.com/inverse-inc/sogo/commit/5b886e5c4dab6bdf486f937df8bb234c4902f50c.diff

Christian Mack

Christian Mack

2014-08-04 04:19

developer   ~0007382

I tried your patch, but now it is worse.
Before I could drag and drop events from the search list to calendars.
Now I only get the same behaviour as with tasks (shown in the above picture Auswahl_001.png)

When dragging an event from a View it is a little bit better.
It only deselects the target folder for dropping, if you move your cursor/mouse over the dragging icon.
Reason for this seems to be,that this icon is moved in steps, not continiously with the dragging cursor/mouse.
And it seems to catch the focus?

Hope this description is clear enough and helps a bit.

francis

francis

2014-08-04 10:50

administrator   ~0007383

I no longer have any problem with Firefox 31 and the latest version of SchedulerUI.js. Are you sure you've properly updated the JavaScript file?

Christian Mack

Christian Mack

2014-08-04 11:59

developer   ~0007384

Just got the nightlies 2.2.7.20140804 installed and retested.
With these Drag&Drop for tasks and events works.
Also the deselects of the target folder are gone.

Seems that I was missing another change than the one in 0002759:0007378 which affeted this behaviour.
(I double checked my changes of SchedulerUI.js before)

acloutier

acloutier

2014-08-27 16:04

viewer   ~0007438

@Jens Erat : I was able to reproduce and isolate the cause of the bug you found when dragging an event from the calendar view over the calendar list on the left panel. I made a quick fix about it:

https://github.com/inverse-inc/sogo/commit/03152ea3d4cbf39ef8a5340e865d038bc899877f

Thank you for your feedback
-Alexandre

Issue History

Date Modified Username Field Change
2014-05-09 09:14 Jens Erat New Issue
2014-05-09 09:57 francis Target Version => 3.0.0
2014-07-21 14:22 ludovic Note Added: 0007340
2014-07-21 14:22 ludovic Status new => resolved
2014-07-21 14:22 ludovic Fixed in Version => 2.2.7
2014-07-21 14:22 ludovic Resolution open => fixed
2014-07-21 14:22 ludovic Assigned To => ludovic
2014-07-24 07:46 Christian Mack Note Added: 0007344
2014-07-24 07:46 Christian Mack Status resolved => feedback
2014-07-24 07:46 Christian Mack Resolution fixed => reopened
2014-07-24 08:04 ludovic Note Added: 0007345
2014-07-24 08:18 Jens Erat Note Added: 0007346
2014-07-24 08:18 Jens Erat Status feedback => assigned
2014-07-24 14:05 ludovic Note Added: 0007347
2014-07-29 10:38 ludovic Status assigned => closed
2014-07-29 10:38 ludovic Resolution reopened => fixed
2014-08-01 05:51 Jens Erat Note Added: 0007375
2014-08-01 05:51 Jens Erat Status closed => feedback
2014-08-01 05:51 Jens Erat Resolution fixed => reopened
2014-08-01 05:57 Jens Erat Note Edited: 0007375
2014-08-01 05:57 Jens Erat File Added: Auswahl_001.png
2014-08-01 12:59 francis Note Added: 0007378
2014-08-04 04:19 Christian Mack Note Added: 0007382
2014-08-04 10:50 francis Note Added: 0007383
2014-08-04 11:59 Christian Mack Note Added: 0007384
2014-08-27 16:04 acloutier Note Added: 0007438
2014-08-27 16:13 acloutier Status feedback => resolved
2014-08-27 16:13 acloutier Resolution reopened => fixed