View Issue Details

IDProjectCategoryView StatusLast Update
0000272SOGoBackend Calendarpublic2014-07-25 09:35
Reportercwright Assigned Towsourdeau 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionnightly v2 
Target Version1.3.3Fixed in Version1.3.3 
Summary0000272: Calendar sync tag names are not released when a calendar is deleted
Description

1) Create a calendar Test.

2) Enable synchronization of the calendar and give the tag name test.

3) Delete the calendar Test.

4) Recreating the Test calendar and attempting to again give the sync tag name test results in the following error dialog:

"The tag you specified is already associated to another calendar."

Additional Information

Manually removing the tag name from c_settings in sogo_user_profile allows the tag name to be reused again.

Noted this behavior in SOGo 1.1.0 and 200912030644.

TagsNo tags attached.

Relationships

has duplicate 0000824 resolvedludovic deleting calendar does not delete its sync tag 
has duplicate 0000873 resolvedludovic Sync Tags should be deleted with calendar 
related to 0000893 closed sogo-tool ability to cleanup old calendar sync tags 

Activities

wsourdeau

wsourdeau

2010-10-08 10:32

viewer   ~0001577

Most calendar preferences are not released in that case. It would be useful to do this, especially since there is normalization mechanism.

wsourdeau

wsourdeau

2010-10-08 15:54

viewer   ~0001586

Fixed in c1871a78b402c35ce922ac5da7c7d2256dc9bb0c. Please note that the fix will work only for new subscriptions and folders created from now on. Old references will need to be removed by resubscribing and unsubscribing from the corresponding folders.

Issue History

Date Modified Username Field Change
2009-12-03 20:43 cwright New Issue
2009-12-18 14:46 ludovic Status new => assigned
2009-12-18 14:46 ludovic Assigned To => ludovic
2010-09-14 14:42 ludovic Relationship added has duplicate 0000824
2010-09-30 14:14 ludovic Relationship added has duplicate 0000873
2010-09-30 14:14 ludovic Target Version => 1.3.3
2010-10-08 10:32 wsourdeau Note Added: 0001577
2010-10-08 15:09 wsourdeau Assigned To ludovic => wsourdeau
2010-10-08 15:54 wsourdeau Note Added: 0001586
2010-10-08 15:54 wsourdeau Status assigned => resolved
2010-10-08 15:54 wsourdeau Fixed in Version => 1.3.3
2010-10-08 15:54 wsourdeau Resolution open => fixed
2014-07-25 09:35 Christian Mack Relationship added related to 0000893