View Issue Details

IDProjectCategoryView StatusLast Update
0002713SOGoActiveSyncpublic2014-10-16 13:28
Reporterjameswilson Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platform[Server] LinuxOSRHEL/CentOSOS Version5
Product Versionnightly v2 
Fixed in Version2.2.10 
Summary0002713: ActiveSync WP8
Description

i have tried to setup wp8 to use sogo active sync on lumia 920.
errorcode is 85002012. I have also tried surface tab on activesync and it fails.

Steps To Reproduce

wp8.1 i have tested 2 handsets with the same result

Additional Information

I hzve logs availsble but unsure which are useful

TagsNo tags attached.

Activities

ludovic

ludovic

2014-04-12 13:29

administrator   ~0006879

Please provide a full tcpdump on localhost/port 20000 when you create a new WP8 AS profile and it fails.

jameswilson

jameswilson

2014-04-12 15:00

reporter   ~0006880

ludovic. id love too but how do i do that?

ludovic

ludovic

2014-04-12 15:16

administrator   ~0006881

tcpdump -i lo -s 0 -w /tmp/dump.pcap tcp and port 20000

jameswilson

jameswilson

2014-04-12 16:18

reporter   ~0006882

dump as follows thanks for the instruction


Ôò¡  ÿÿ  tžISÕò
B B  E 4£½@ @™  šHN ¯ PG×¾ €´ 
$¿¼mª^tžISÜò
6 6  E ( @ @<Î  N šHG×¾ P Ý tžISßò
J J  E <§@ @¯  šØN ~2  €1’ @ 
$¿¼ tžISâò
J J  E < @ @<º  N šØáû8±~2 € R @ 
$¿¼$¿¼tžISåò
B B  E 4¨@ @¯  šØN ~2áû8²€:/ 
$¿¼$¿¼tžISèò
   E  ©@ @­@  šØN ~2áû8²€DB 
$¿¼$¿¼OPTIONS /SOGo/Microsoft-Server-ActiveSync?User=james.wilson&DeviceId=34F7B4D7D7007DE93660A1225CA5C624&DeviceType=WP8 HTTP/1.1
Host: 127.0.0.1:20000
Cache-Control: no-cache
Pragma: no-cache
Authorization: Basic c2VjdXJpdHl3YXJlaG91c2VcamFtZXMud2lsc29uOjQ5MDIzM1RpbGx5LQ==
User-Agent: MSFT-WP/8.0.10517
MS-ASProtocolVersion: 14.1
X-Forwarded-For: 82.132.234.158
X-Forwarded-Host: 81.143.33.107
X-Forwarded-Server: securitywarehouse.co.uk
Connection: Keep-Alive

tžISëò
B B  E 4‡@ @µ³  N šØáû8²~3ô€ 8O 
$¿¼$¿¼tžISíò
S S  E E‡@ @µ¡  N šØáû8²~3ô€ xf 
$¿Æ$¿¼HTTP/1.1 200 OK
tžISðò
B B  E 4ª@ @¯  šØN ~3ôáû8À82 
$¿Æ$¿ÆtžISóò
1 1  E #‡@ @³Â  N šØáû8Ã~3ô€ å 
$¿Æ$¿ÆCache-Control: private
MS-ASProtocolVersions: 2.0,2.1,2.5,12.0,12.1,14.0,14.1
Content-Length: 0
Allow: OPTIONS, POST
MS-Server-ActiveSync: 14.1
Content-Type: text/plain
Public: OPTIONS, POST
MS-ASProtocolCommands: Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateCollection,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse,Search,Settings,Ping,ItemOperations,ResolveRecipients,ValidateCert
tžISöò
B B  E 4«@ @¯  šØN ~3ôáû:²€ 6; 
$¿Æ$¿ÆtžISùò
D D  E 6‡@ @µ®  N šØáû:²~3ô€ )' 
$¿Æ$¿Æ
tžISüò
B B  E 4¬@ @¯  šØN ~3ôáû:´€ 69 
$¿Æ$¿ÆtžISÿò
B B  E 4‡@ @µ¯  N šØáû:´~3ô€ 68 
$¿Æ$¿ÆtžISW™ B B  E 4­@ @¯  šØN ~3ôáû:µ€ 6 
$¿î$¿Æ¡žISÅ B B  E 4`î@ @ÛÓ  ™ÄN þÇÀ8j©hr€«Ü 
%kÎ Þßð¡žISß 6 6  E ( @ @<Î  N ™Äj©hr P öÝ ¡žIS  J J  E <¦º@ @•ÿ  šÝN gÍt  € @ 
%kÎ ¡žIS  J J  E < @ @<º  N šÝjÕgÍu € ± @ 
%kÎ%kΡžIS)  B B  E 4¦»@ @–  šÝN gÍujÖ€öÔ 
%kÎ%kΡžIS-Œ    E ò¦¼@ @”G  šÝN gÍujÖ€… 
%l2%kÎPOST /SOGo/Microsoft-Server-ActiveSync?jREJCBA097TX1wB96TZgoSJcpcYkBAAAAAADV1A4 HTTP/1.1
Host: 127.0.0.1:20000
Cache-Control: no-cache
Pragma: no-cache
Content-Type: application/vnd.ms-sync
Authorization: Basic c2VjdXJpdHl3YXJlaG91c2VcamFtZXMud2lsc29uOjQ5MDIzM1RpbGx5LQ==
X-Forwarded-For: 82.132.234.158
X-Forwarded-Host: 81.143.33.107
X-Forwarded-Server: securitywarehouse.co.uk
Connection: Keep-Alive
Content-Length: 11

j E]¡žIS;Œ B B  E 4}@ @¿©  N šÝjÖgÏ3€ ôF 
%l2%l2¡žIS” S S  E E}@ @¿—  N šÝjÖgÏ3€ 4h 
%l2%l2HTTP/1.1 200 OK
¡žIS%” B B  E 4¦½@ @–  šÝN gÏ3jç€ô= 
%l2%l2¡žIS£”    E ò}@ @½é  N šÝjçgÏ3€ y 
%l2%l2MS-Server-ActiveSync: 14.1
Content-Type: application/vnd.ms-sync.wbxml
MS-ASProtocolCommands: Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateCollection,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse,Search,Settings,Ping,ItemOperations,ResolveRecipients,ValidateCert
MS-ASProtocolVersions: 2.0,2.1,2.5,12.0,12.1,14.0,14.1
Content-Length: 19
¡žIS¬” B B  E 4¦¾@ @–  šÝN gÏ3j¥€ òw 
%l2%l2¡žISä” D D  E 6}@ @¿¤  N šÝj¥gÏ3€ åc 
%l2%l2
¡žISì” B B  E 4¦¿@ @–  šÝN gÏ3j§€ òu 
%l2%l2¡žIS,– U U  E G}@ @¿’  N šÝj§gÏ3€ û‹ 
%l2%l2j E F1 ¡žIS6– B B  E 4¦À@ @–  šÝN gÏ3jº€ òb 
%l2%l2¡žISK— B B  E 4}@ @¿¤  N šÝjºgÏ3€ òa 
%l2%l2¡žISŽD
B B  E 4¦Á@ @–   šÝN gÏ3j»€ ò9 
%lZ%l2£žISš B B  E 4¦Â@ @•ÿ  šÝN gÏ3j»€ ì 
%r%l2£žISÏ B B  E 4 @ @<  N šÝj»gÏ4€ å¤ 
%r%r£žISG J J  E <øÄ@ @Cõ  šÞN PŠT  €˜4 @ 
%r £žIST J J  E < @ @<º  N šÞV¼›Š PŠU € .? @ 
%r%r£žIS^ B B  E 4øÅ@ @Cü  šÞN PŠUV¼›‹€c 
%r%r£žIS^e    E ôøÆ@ @B;  šÞN PŠUV¼›‹€ p 
%sb%rPOST /SOGo/Microsoft-Server-ActiveSync?jQkJCBA097TX1wB96TZgoSJcpcYkBAAAAAADV1A4 HTTP/1.1
Host: 127.0.0.1:20000
Cache-Control: no-cache
Pragma: no-cache
Content-Type: application/vnd.ms-sync
Authorization: Basic c2VjdXJpdHl3YXJlaG91c2VcamFtZXMud2lsc29uOjQ5MDIzM1RpbGx5LQ==
X-Forwarded-For: 82.132.234.158
X-Forwarded-Host: 81.143.33.107
X-Forwarded-Server: securitywarehouse.co.uk
Connection: Keep-Alive
Content-Length: 13

j VR0 £žISme B B  E 4é@ @S¦  N šÞV¼›‹ PŒ€ ÷ 
%sb%sb£žIS, S S  E Eé@ @S”  N šÞV¼›‹ PŒ€ R 
%t\%sbHTTP/1.1 200 OK
£žIS‹, B B  E 4øÇ@ @Cú  šÞN PŒV¼›œ€ú 
%t\%t\£žIS3-    E ôé@ @Qä  N šÞV¼›œ PŒ€ ^ 
%t\%t\MS-Server-ActiveSync: 14.1
Content-Type: application/vnd.ms-sync.wbxml
MS-ASProtocolCommands: Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateCollection,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse,Search,Settings,Ping,ItemOperations,ResolveRecipients,ValidateCert
MS-ASProtocolVersions: 2.0,2.1,2.5,12.0,12.1,14.0,14.1
Content-Length: 1089
£žIS=- B B  E 4øÈ@ @Cù  šÞN PŒV¼\€ 2 
%t\%t\£žISx- D D  E 6é@ @S¡  N šÞV¼\ PŒ€  
%t\%t\
£žIS- B B  E 4øÉ@ @Cø  šÞN PŒV¼^€ 0 
%t\%t\£žISø. B B  E 4é@ @Q¢  N šÞV¼^ PŒ€ L 
%t\%t\j VL1 R1 NW21 OHmail%2FINBOX I0 J2 GINBOX OHmail%2FDrafts I0 J3 GDrafts OHmail%2FSent I0 J5 GSent OHmail%2FTrash I0 J4 GTrash OHmail%2FArchives I0 J12 GArchives OHmail%2FArchives%2F2010 Imail%2FArchives J12 G2010 OHmail%2FArchives%2F2011 Imail%2FArchives J12 G2011 OHmail%2FDeleted%20Items I0 J12 GDeleted Items OHmail%2FForum%20Questions I0 J12 GForum Questions OHmail%2FJunk I0 J12 GJunk OHmail%2FJunk%20E-mai£žIS/ B B  E 4øÊ@ @C÷  šÞN PŒV¼Ÿ^€
( 
%t\%t\£žISú/ B B  E 4é @ @Q¡  N šÞV¼Ÿ^ PŒ€ cR 
%t\%t\l I0 J12 GJunk E-mail OHmail%2Fjunkmail I0 J12 Gjunkmail OHmail%2FLearnAsSpam I0 J12 GLearnAsSpam OHmail%2Fold%20inbox I0 J12 Gold inbox OHmail%2FSaved%20Stuff I0 J12 GSaved Stuff OHmail%2FSaved%20Stuff%2Ftelephone%20system Imail%2FSaved%20Stuff J12 Gtelephone system OHmail%2FSent%20Items I0 J12 GSent Items OHmail%2Fsent-mail I0 J12 Gsent-mail OHvevent/personal I0 J8 GPersonal Calendar OHvtodo/personal I0 J7 GPersonal Cal£žIS0 B B  E 4øË@ @Cö  šÞN PŒV¼¡^€  
%t\%t\£žISò0 ƒ ƒ  E ué!@ @S_  N šÞV¼¡^ PŒ€ Q 
%t\%t\endar OHvcard/personal I0 J9 GPersonal Address Book £žISû0 B B  E 4øÌ@ @Cõ  šÞN PŒV¼¡Ÿ€
Þ 
%t\%t\£žISt1 B B  E 4é"@ @SŸ  N šÞV¼¡Ÿ PŒ€
î 
%t\%t\£žISZË B B  E 4øÍ@ @Cô  šÞN PŒV¼¡ €
µ 
%t„%t\

ludovic

ludovic

2014-04-22 14:38

administrator   ~0006949

I can't do anything with this.

Attach the pcap file, don't copy/paste its content.

jameswilson

jameswilson

2014-04-25 13:21

reporter  

dump(1).pcap (8,314 bytes)
jameswilson

jameswilson

2014-04-25 13:22

reporter   ~0006962

i have attached a new dump.

ludovic

ludovic

2014-05-05 14:17

administrator   ~0006991

The request/response looks good - I don't know why the device bails out after.

This would need to be investigated but since we don't have any WP8 devices, it might take a while before we figure out what could be wrong.

ludovic

ludovic

2014-06-11 15:13

administrator   ~0007193

You might want to retry with the latest nightly builds. Don't forget to recreate the profile.

andrew

andrew

2014-06-12 13:27

reporter   ~0007205

Last edited: 2014-06-12 13:27

The result was same as what jameswilson done using lastest nightly builds in Lumia 920/1020.But andoid and ios system are normal.

ludovic

ludovic

2014-06-16 10:20

administrator   ~0007212

Andrew, since you've submitted patches in the past, you might want to toy around with the response sent back in the ActiveSync code as we don't have access to a WP device.

andrew

andrew

2014-06-17 01:21

reporter   ~0007220

The problem may be caused by data type error.

All the response data type in sogo activesync are string, but the protocol defined different data type, such as status code, must be unsignedByte type or integer type.

The other device maybe covert from string to integer type in status code,but wp8 didn't.

andrew

andrew

2014-06-17 02:24

reporter   ~0007221

ActiveSync XML schema
http://msdn.microsoft.com/en-us/library/dn292969(v=exchg.80).aspx

Does libwbxml support using xml schema(not dtd) convert to wbxml?

libor.neuzil

libor.neuzil

2014-07-03 10:07

reporter   ~0007279

I have the same issue

tfu

tfu

2014-10-05 14:39

reporter   ~0007587

The problem migth be the base64 encoded query-string sent by the WP:
http://msdn.microsoft.com/en-us/library/ee160227%28v=exchg.80%29.aspx

ludovic

ludovic

2014-10-16 13:28

administrator   ~0007613

Should be fixed with this commit:

https://github.com/inverse-inc/sogo/commit/fb95d84a3a4eb1c3f329a02a4496cc7528f17c2a

Please try the nightly builds that were generated a few minutes ago.

Issue History

Date Modified Username Field Change
2014-04-11 19:31 jameswilson New Issue
2014-04-12 13:29 ludovic Note Added: 0006879
2014-04-12 15:00 jameswilson Note Added: 0006880
2014-04-12 15:16 ludovic Note Added: 0006881
2014-04-12 16:18 jameswilson Note Added: 0006882
2014-04-22 14:38 ludovic Note Added: 0006949
2014-04-25 13:21 jameswilson File Added: dump(1).pcap
2014-04-25 13:22 jameswilson Note Added: 0006962
2014-05-05 14:17 ludovic Note Added: 0006991
2014-06-11 15:13 ludovic Note Added: 0007193
2014-06-12 13:27 andrew Note Added: 0007205
2014-06-12 13:27 andrew Note Edited: 0007205
2014-06-16 10:20 ludovic Note Added: 0007212
2014-06-17 01:21 andrew Note Added: 0007220
2014-06-17 02:24 andrew Note Added: 0007221
2014-07-03 10:07 libor.neuzil Note Added: 0007279
2014-10-05 14:39 tfu Note Added: 0007587
2014-10-16 13:28 ludovic Note Added: 0007613
2014-10-16 13:28 ludovic Status new => closed
2014-10-16 13:28 ludovic Assigned To => ludovic
2014-10-16 13:28 ludovic Resolution open => fixed
2014-10-16 13:28 ludovic Fixed in Version => 2.2.10