View Issue Details

IDProjectCategoryView StatusLast Update
0002707SOGo IntegratorBackend Calendarpublic2016-12-22 15:56
Reportermbi Assigned Toludovic  
PriorityhighSeveritymajorReproducibilityhave not tried
Status resolvedResolutionduplicate 
Platform[Client] AppleOSiOSOS Version7.1
Product Version24.0.4 
Summary0002707: Wrong Time/timezone for accepted event showing in iPhone and Thunderbird, shows correct in SOGo web GUI
Description

User was invited to an event from someone on the West Coast (PST).

The external organizer set the event time to 8:00am PST.

She accepted the event on her iPhone.

The event was added to her calendar, but shows in both their iPhone and Thunderbird as being scheduled for 8:00am EST, when it should show 4:00am EST.

Timezone is set correctly in iPhone, Thunderbird and SOGo, and interestingly the event does display correctly as scheduled for 4:00am in their SOGo web GUI...

Steps To Reproduce
  1. Have organizer send invitation to event from West Coast/PST timezone.

  2. Accept invitation on iPhone

  3. Note that the time the event shows scheduled for on the iPhone (and in Thunderbird with Integrator) is the wrong time (shows as the same time as the organizer, but in the participants timezone, which is wrong).

Additional Information

iPhone 5S, iOS version 7.1

As I said, also displaying incorrectly in Thunderbird 24.4, Lightning 2.6.4, SOGo Connector/Integrator versions 24.0.4.

TagsNo tags attached.

Relationships

duplicate of 0002865 resolvedludovic SOGo SOGo does not interpret date-time without timezone correctly 
has duplicate 0002716 resolvedludovic SOGo Wrong time/timezone for Calendar Invite when accepted on iPhone, OK when accepted on Thunderbird 

Activities

mbi

mbi

2014-04-10 07:15

reporter   ~0006870

Oops...

It was not an iPhone 5S, just the plain 5...

Sorry...

mbi

mbi

2014-04-11 06:42

reporter   ~0006872

Ok, the problem only occurs when she accepts the invite on her iPhone. When she accepts it from Thunderbird, the time is displayed correctly.

Also, I was wrong earlier...

When she accepts it on her iPhone, the time displayed in SOGo web UI is way wrong - it shows 4:00am for an 8:00am PST event, when it should have showed 11:00am EST.

francis

francis

2014-04-11 08:06

administrator   ~0006875

Can you show the raw source (vCalendar) of the event once the participant has accepted the invitation? You can view the raw source by ctrl-clicking on the event in the Web interface.

mbi

mbi

2014-04-11 09:01

reporter   ~0006876

Thanks... I would, but apparently she manually changed the date/time (or deleted/re-added the event with the right date/time), because I don't see it in her calendar any more.

First I'm going to try to find a way to reproduce this locally so we don't have to bug her business contact to help in troubleshooting.

If I can't, I'll ask him if he is ok with helping just a little more... he seems nice enough, so I don't think it will be a problem.

mbi

mbi

2014-04-11 09:47

reporter   ~0006877

Last edited: 2014-04-11 14:26

Ok, I forgot we did a few more tests, and there is still one in the calendar displaying the wrong date/time...

This one was scheduled for 2:00pm PST, and is displaying as 10:00am EST, when it should be 5:00pm EST...

***** Begin Event Source

BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VEVENT
CREATED:20140411T125552Z
LAST-MODIFIED:20140411T125831Z
DTSTAMP:20140411T125831Z
UID:60EC15A4-2B0B-48B4-8CA1-9BBD2EDA3BF2
SUMMARY:Quantcast Test Invite 0000002
PRIORITY:5
STATUS:CONFIRMED
ATTENDEE;PARTSTAT=NEEDS-ACTION;ROLE=REQ-PARTICIPANT;EMAIL=CMarcus@Media-Bro
kers.com;RSVP=TRUE;CUTYPE=INDIVIDUAL;CN=Charles Marcus:mailto:CMarcus@Medi
a-Brokers.com
ATTENDEE;PARTSTAT=NEEDS-ACTION;ROLE=REQ-PARTICIPANT;EMAIL=MStacy@Media-Brok
ers.com;CUTYPE=INDIVIDUAL;CN=Marina Stacy:mailto:MStacy@Media-Brokers.com
DTSTART:20140411T140000
DTEND:20140411T143000
CLASS:PUBLIC
DESCRIPTION:When: Friday\, April 11\, 2014 2:00 PM-2:30 PM. Pacific Standar
d Time\n\n~~~~~~~~~\n\n
SEQUENCE:0
TRANSP:OPAQUE
X-MICROSOFT-CDO-APPT-SEQUENCE:0
X-MICROSOFT-CDO-BUSYSTATUS:TENTATIVE
X-MICROSOFT-CDO-IMPORTANCE:1
X-MICROSOFT-CDO-INSTTYPE:0
X-MICROSOFT-CDO-INTENDEDSTATUS:BUSY
X-MICROSOFT-CDO-OWNERAPPTID:2112115687
X-MOZ-GENERATION:1
BEGIN:VALARM
ACTION:DISPLAY
TRIGGER;X-WEBSTATUS=triggered;VALUE=DURATION:-PT15M
DESCRIPTION:Default Mozilla Description
END:VALARM
ORGANIZER;CN=Ryan Boursse;EMAIL=rboursse@quantcast.com:mailto:rboursse@quan
tcast.com
END:VEVENT
END:VCALENDAR

**** End Event Source

mbi

mbi

2014-04-13 11:03

reporter   ~0006883

So... did that help disclose the problem?

Christian Mack

Christian Mack

2014-04-14 07:33

developer   ~0006888

Last edited: 2014-04-14 07:48

This event does not contain a timezone at all!!!

Start and End are not in GMT/UTC either (mizzing 'Z'-character at the end):
DTSTART:20140411T140000
DTEND:20140411T143000

SOGo seems to read these as GMT/UTC.
Shouldn't it read them as "local" time, which would be EST here?
(This would still be wrong, but seems to be more logical, at least for me.)

But more important, who stripped the timezone in such a crappy way?

ludovic

ludovic

2014-04-14 07:47

administrator   ~0006889

SOGo will read them as local time, not UTC.

It would read them as UTC if a Z was ending the date-time.

mbi

mbi

2014-04-14 08:38

reporter   ~0006890

So... this appears to be a bug that happens for invitations received from someone using Exchange when the invite is accepted on an iOS 7.1 device?

Also, as I said, invites from this person that are accepted from Thunderbird+Integrator show up correctly.

To summarize:

  1. Invites from the outside user (using Exchange) are accepted correctly from Thunderbird+Integrator, and display the correct time in SOGo, Thunderbird and the iPhone.

  2. The same invites from the same outside user are broken when accepted from an iOS 7.1 device (iPhone at least):

    a) SOGo displays the time as Organizer timezone - 4hours (ie, 8:00am PST event displays as 4:00am in SOGo which is set to EDT timezone)

    b) Thunderbird displays the time at the same time as the Organizer timezone (ie, 8:00am), with Thunderbird set to EDT timezone

So, there is a serious discrepancy here somewhere...

Can we arrange for the person who has been helping us to invite one of the SOGo developers directly, so you guys can properly troubleshoot this?

Thanks,

Charles

ludovic

ludovic

2016-12-22 15:56

administrator   ~0011099

Closing this one for now, we'll track only 2865 as more details are in there.

Issue History

Date Modified Username Field Change
2014-04-10 07:05 mbi New Issue
2014-04-10 07:15 mbi Note Added: 0006870
2014-04-11 06:42 mbi Note Added: 0006872
2014-04-11 08:03 francis OS Windows => iOS
2014-04-11 08:03 francis OS Version 7 => 7.1
2014-04-11 08:03 francis Platform [Client] Microsoft => [Client] Apple
2014-04-11 08:06 francis Note Added: 0006875
2014-04-11 09:01 mbi Note Added: 0006876
2014-04-11 09:47 mbi Note Added: 0006877
2014-04-11 14:26 mbi Note Edited: 0006877
2014-04-13 11:03 mbi Note Added: 0006883
2014-04-14 07:33 Christian Mack Note Added: 0006888
2014-04-14 07:46 Christian Mack Note Edited: 0006888
2014-04-14 07:47 ludovic Note Added: 0006889
2014-04-14 07:48 Christian Mack Note Edited: 0006888
2014-04-14 08:38 mbi Note Added: 0006890
2014-04-16 06:05 Christian Mack Relationship added has duplicate 0002716
2016-12-22 15:56 ludovic Note Added: 0011099
2016-12-22 15:56 ludovic Relationship added duplicate of 0002865
2016-12-22 15:56 ludovic Status new => resolved
2016-12-22 15:56 ludovic Resolution open => duplicate
2016-12-22 15:56 ludovic Assigned To => ludovic