View Issue Details

IDProjectCategoryView StatusLast Update
0002701SOGoPackaging (Debian)public2014-11-06 11:27
Reporterrolf Assigned Toludovic  
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Platform[Server] LinuxOSDebianOS Version7 (Wheezy)
Product Version2.2.3 
Target Version2.2.10Fixed in Version2.2.10 
Summary0002701: sogo apt repository breaking sssd on wheezy (libldb1)
Description

When adding the regular Wheezy SOGo repository and updating a stock Wheezy installation, I end up with:

root@debian72:/var/www# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
libldb1 libtevent0
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 167 kB of archives.

If I run these two updates, I end up with a newer version of libldb1 (1:1.1.13-1 vs 1:1.1.6-1) which basically breaks the stock sssd:

root@debian72:/etc# /etc/init.d/sssd restart
ldb: module version mismatch in ../src/ldb_modules/memberof.c : ldb_version=1.1.13 module_version=1.1.6
ldb: failed to initialise module /usr/lib/x86_64-linux-gnu/ldb/modules/ldb/memberof.so : Unavailable
[FAIL] Starting System Security Services Daemon: sssd failed!
root@debian72:/etc#

Additional Information

This was first reported by mourik jan heupink on the mailing list on Thu, 23 Jan 2014 17:29:02 +0100 and also confirmed by Michal Kminek for CentOS 6.

On my installation, the issue was unnoticed for several month as I did not require any sssd restart in the meantime. After a forced sssd restart (server shutdown / restart), however, logging into the server via sssd suddenly became impossible.

I suspect that other installations are also at risk by this hidden "time bomb" that might only show up after the next server reboot.

TagsNo tags attached.

Activities

Christian Mack

Christian Mack

2014-04-07 04:45

developer   ~0006836

Mailinglist entries:
https://lists.inverse.ca/sogo/arc/users/2014-01/msg00215.html

m0ps

m0ps

2014-07-04 03:29

reporter   ~0007282

Last edited: 2014-07-04 03:31

View 2 revisions

Also affected: ubuntu 12.04 x64 server with sogo 2.2.6. Stock libldb1 version is 1.1.4

ludovic

ludovic

2014-11-06 11:27

administrator   ~0007663

This should not happen anymore with the nightly builds or the upcoming 2.2.10 release. Please confirm.

Issue History

Date Modified Username Field Change
2014-04-05 05:15 rolf New Issue
2014-04-07 04:45 Christian Mack Note Added: 0006836
2014-07-04 03:29 m0ps Note Added: 0007282
2014-07-04 03:31 m0ps Note Edited: 0007282 View Revisions
2014-09-12 11:23 ludovic Target Version => 2.2.9
2014-09-26 09:37 ludovic Target Version 2.2.9 => 2.2.10
2014-11-06 11:27 ludovic Note Added: 0007663
2014-11-06 11:27 ludovic Status new => resolved
2014-11-06 11:27 ludovic Fixed in Version => 2.2.10
2014-11-06 11:27 ludovic Resolution open => fixed
2014-11-06 11:27 ludovic Assigned To => ludovic