View Issue Details

IDProjectCategoryView StatusLast Update
0002653SOGoActiveSyncpublic2014-03-11 13:22
Reporterkiju Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platform[Client] GoogleOSAndroidOS VersionJelly Bean
Product Version2.2.1 
Fixed in Version2.2.2 
Summary0002653: Calendar won't sync
Description

If I create event on Webpage everything is fine, phone synchronize events. but if I delete all event and create new on the phone synchronizations breaks. Log file show:
Mar 11 15:17:21 sogod [23769]: <0x0x7f5078593960[SOGoCache]> Cache cleanup interval set every 300.000000 seconds
Mar 11 15:17:21 sogod [23769]: <0x0x7f5078593960[SOGoCache]> Using host(s) 'localhost' as server(s)
2014-03-11 15:17:22.059 sogod[23769] -[WEClientCapabilities initWithRequest:]: Unknown WebClient: user-agent='SonyC2005/4.2.2-EAS-1.3'
2014-03-11 15:17:22.062 sogod[23769] Note(SoObject): SoDebugKeyLookup is enabled!
2014-03-11 15:17:22.062 sogod[23769] Note(SoObject): SoDebugBaseURL is enabled!
2014-03-11 15:17:22.063 sogod[23769] Note(SoObject): relative base URLs are enabled.
Mar 11 15:17:22 sogod [23769]: [WARN] <0x0x7f50787d31b0[SOGoWebDAVAclManager]> entry '{DAV:}write' already exists in DAV permissions table
Mar 11 15:17:22 sogod [23769]: [WARN] <0x0x7f50787d31b0[SOGoWebDAVAclManager]> entry '{DAV:}write-properties' already exists in DAV permissions table
Mar 11 15:17:22 sogod [23769]: [WARN] <0x0x7f50787d31b0[SOGoWebDAVAclManager]> entry '{DAV:}write-content' already exists in DAV permissions table
EXCEPTION: <NSException: 0x7f5078989500> NAME:NSInvalidArgumentException REASON:SoHTTPException(instance) does not recognize delete INFO:(null)
Mar 11 15:17:22 sogod [22592]: <0x0x7f507828ae10[WOWatchDogChild]> child 23769 exited
Mar 11 15:17:22 sogod [22592]: <0x0x7f507828ae10[WOWatchDogChild]> (terminated due to signal 6)
Mar 11 15:17:22 sogod [22592]: <0x0x7f50781d4530[WOWatchDog]> child spawned with pid 23772

TagsNo tags attached.

Activities

kiju

kiju

2014-03-11 11:03

reporter   ~0006685

on another phone after few event create/delete the same error:

Mar 11 15:59:11 sogod [24470]: <0x0x7f37c2dba9d0[SOGoCache]> Cache cleanup interval set every 300.000000 seconds
Mar 11 15:59:11 sogod [24470]: <0x0x7f37c2dba9d0[SOGoCache]> Using host(s) 'localhost' as server(s)
2014-03-11 15:59:11.610 sogod[24470] -[WEClientCapabilities initWithRequest:]: Unknown WebClient: user-agent='Android/4.2.2-EAS-1.3'
2014-03-11 15:59:11.612 sogod[24470] Note(SoObject): SoDebugKeyLookup is enabled!
2014-03-11 15:59:11.613 sogod[24470] Note(SoObject): SoDebugBaseURL is enabled!
2014-03-11 15:59:11.613 sogod[24470] Note(SoObject): relative base URLs are enabled.
Mar 11 15:59:11 sogod [24470]: [WARN] <0x0x7f37c2e46c80[SOGoWebDAVAclManager]> entry '{DAV:}write' already exists in DAV permissions table
Mar 11 15:59:11 sogod [24470]: [WARN] <0x0x7f37c2e46c80[SOGoWebDAVAclManager]> entry '{DAV:}write-properties' already exists in DAV permissions table
Mar 11 15:59:11 sogod [24470]: [WARN] <0x0x7f37c2e46c80[SOGoWebDAVAclManager]> entry '{DAV:}write-content' already exists in DAV permissions table
EXCEPTION: <NSException: 0x7f37c2f3c090> NAME:NSInvalidArgumentException REASON:SoHTTPException(instance) does not recognize delete INFO:(null)
Mar 11 15:59:11 sogod [23889]: <0x0x7f37c2ba8df0[WOWatchDogChild]> child 24470 exited
Mar 11 15:59:11 sogod [23889]: <0x0x7f37c2ba8df0[WOWatchDogChild]> (terminated due to signal 6)

delete ActiveSync account on the phone resolves issue

ludovic

ludovic

2014-03-11 12:04

administrator   ~0006686

So you get the error when you try to delete an event from the phone?

kiju

kiju

2014-03-11 12:58

reporter   ~0006688

No, scenario is:

  • connect mobile phone with ActiveSync - sync working
  • create event on webpage - sync working
  • delete event on phone - sync working
  • create event on phone - sync no longer working
ludovic

ludovic

2014-03-11 13:22

administrator   ~0006689

I'm not fully sure how can this happen but I've added a safety check to prevent it.

https://github.com/inverse-inc/sogo/commit/1bdf88fb67f89361978e601da6c5ed74b3042f27

Issue History

Date Modified Username Field Change
2014-03-11 10:42 kiju New Issue
2014-03-11 11:03 kiju Note Added: 0006685
2014-03-11 12:04 ludovic Note Added: 0006686
2014-03-11 12:58 kiju Note Added: 0006688
2014-03-11 13:22 ludovic Note Added: 0006689
2014-03-11 13:22 ludovic Status new => closed
2014-03-11 13:22 ludovic Assigned To => ludovic
2014-03-11 13:22 ludovic Resolution open => fixed
2014-03-11 13:22 ludovic Fixed in Version => 2.2.2