View Issue Details

IDProjectCategoryView StatusLast Update
0002599SOGowith SOGopublic2016-12-16 15:54
Reporterahunt83 Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformAny 
Target VersionsoonFixed in Version3.2.5 
Summary0002599: Duplicate calendar notifications
Description

There is a problem, which can be reproduced using the iCal4OL plugin, where people invited to meetings in Outlook get a double email notification. It seems that Outlook will always send out an invite (and I'm guessing some other clients will as well) and then when Sogo gets the request it also sends the invites out.

From talking to the iCal4OL developer it seems that there is a part of the CalDav spec to support looking for:

SCHEDULE-AGENT=CLIENT

In the event and if that is present then Sogo shouldn't send out emails regarding the event. I'm not sure how hard this would be to implement but it would be a massive help in us being able to provide a nice clean experience to our Exchange converts.

Steps To Reproduce

Using the iCal4OL plugin connected to a Sogo calendar create an appointment and invite another user. Then run a sync (or wait for an auto sync) and a second email will be sent (providing Sogo has been configured to send emails via the SOGoAppointmentSendEMailNotifications config flag).

TagsNo tags attached.

Activities

rverchere

rverchere

2014-06-03 11:04

reporter   ~0007149

+1, clients that are pure caldav clients (i.e. Mail.app) send invitations twice.

ludovic

ludovic

2014-06-03 11:20

administrator   ~0007150

We already support this:

https://github.com/inverse-inc/sogo/blob/master/SoObjects/Appointments/SOGoAppointmentObject.m#L1436

The property must be set on the organizer.

rverchere

rverchere

2014-06-03 12:38

reporter   ~0007151

Great!

From which SOGo version is it supported?

Shujie

Shujie

2015-02-04 06:25

reporter   ~0008133

+1
Is there a way to stop Outlook send notification by itself?
I use Outlook 2013 with Activesync, but also have the problem.
Besides the mail that Outlook send doesn't work with code: 404 error.

martinsimovic

martinsimovic

2016-01-20 06:27

reporter   ~0009303

We seem to have the same problem. Outlook itself insists in sending notification, later when event is synced via iCal4OL to SOGo, SOGo will send another one.

Setting SOGoAppointmentSendEMailNotifications = NO is not an option since it would kill notifications for Thunderbird clients.

What is the right approach to solve this?

Regards
M.

Related Changesets

sogo: master ab1c699b

2016-12-16 15:51:19

ludovic

Details Diff
(feat) better support for RFC 6638 (schedule-agent) (fixes 0002599) Affected Issues
0002599
mod - SoObjects/Appointments/SOGoAppointmentObject.m Diff File

Issue History

Date Modified Username Field Change
2014-02-05 10:10 ahunt83 New Issue
2014-03-09 16:20 ludovic Target Version => soon
2014-06-03 11:04 rverchere Note Added: 0007149
2014-06-03 11:20 ludovic Note Added: 0007150
2014-06-03 12:38 rverchere Note Added: 0007151
2015-02-04 06:25 Shujie Note Added: 0008133
2016-01-20 06:27 martinsimovic Note Added: 0009303
2016-12-16 15:52 ludovic Changeset attached => sogo master ab1c699b
2016-12-16 15:52 ludovic Assigned To => ludovic
2016-12-16 15:52 ludovic Resolution open => fixed
2016-12-16 15:54 ludovic Status new => resolved
2016-12-16 15:54 ludovic Fixed in Version => 3.2.5