View Issue Details

IDProjectCategoryView StatusLast Update
0002592SOGo ConnectorGUIpublic2014-02-12 08:55
Reporterwimmer Assigned Toludovic  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Fixed in Version24.0.4 
Summary0002592: Wrong recoding non-ASCII characters in Contact categories
Description

TB 24.2, SOGo Integrator 24.0.3, SOGo Connector 24.0.2, SOGo 2.1.1b

SOGo Connector recodes wrong non-ASCII characters in Contact categories.
This bug consequently causes another serious troubles in TB.

When I do the same thing in WebGUI, there is no problem.

Steps To Reproduce

1) I have empty TB profile on Desktop, empty user's data on SOGo server
2) I open TB, install addons, open Contact categories window
=> there are correct names (P?ítel) [1.png]
3) I insert new Contact categorie (zzzP?ítel)
=> names with non-ASCII characters are displayed wrong (PYítel, zzz_PYítel) [2.png]
and they are written wrong into SOGo server ("PY\U00EDtel" instead of "P\U0159\U00EDtel")

TagsNo tags attached.

Relationships

duplicate of 0002420 closedludovic Sogo-connector 17.0.5 cyrillic categories 

Activities

wimmer

wimmer

2014-01-29 08:27

reporter  

1.png (Attachment missing)
wimmer

wimmer

2014-01-29 08:27

reporter  

2.png (Attachment missing)

Issue History

Date Modified Username Field Change
2014-01-29 08:27 wimmer New Issue
2014-01-29 08:27 wimmer File Added: 1.png
2014-01-29 08:27 wimmer File Added: 2.png
2014-02-12 08:55 ludovic Relationship added duplicate of 0002420
2014-02-12 08:55 ludovic Status new => resolved
2014-02-12 08:55 ludovic Fixed in Version => 24.0.4
2014-02-12 08:55 ludovic Resolution open => duplicate
2014-02-12 08:55 ludovic Assigned To => ludovic