View Issue Details

IDProjectCategoryView StatusLast Update
0002587SOGoOpenChange backendpublic2014-02-03 09:55
Reporterturip Assigned Toludovic  
PrioritynormalSeveritycrashReproducibilityrandom
Status closedResolutionfixed 
Platformdebian testingOSdebian testingOS Versiondebian testing
Product Version2.1.1a 
Target Version2.2.0Fixed in Version2.2.0 
Summary0002587: libmemcached errors
Description

during openchange mail sync I get the following error in samba log, followed by a panic:
<0x0x7f87548af900[SOGoCache]> an error occurred when caching value for key 'recipient list not shown+attributes': "ERROR was returned by server"
samba: libmemcached/storage.cc:341: memcached_return_t memcached_send_ascii(memcached_st, memcached_server_write_instance_st, const char, size_t, const char*, size_t, time_t, uint32_t, uint64_t, bool, bool, memcached_storage_action_t): Assertion `memcached_failed(rc)' failed.

It is known that the ascii protocoll of memcached is less stable of the binary protocol.

I have added the following line to SOGoCache.m:117 (init member)

memcached_behavior_set(handle, MEMCACHED_BEHAVIOR_BINARY_PROTOCOL, 1);

This causes the library to use binary protocol, which is implemented since a while and works :)

TagsNo tags attached.

Issue History

Date Modified Username Field Change
2014-01-24 09:01 turip New Issue
2014-01-30 22:26 ludovic Target Version => 2.2.0
2014-02-03 09:55 ludovic Note Added: 0006469
2014-02-03 09:55 ludovic Status new => closed
2014-02-03 09:55 ludovic Assigned To => ludovic
2014-02-03 09:55 ludovic Resolution open => fixed
2014-02-03 09:55 ludovic Fixed in Version => 2.2.0