View Issue Details

IDProjectCategoryView StatusLast Update
0002565SOGoWeb Calendarpublic2014-02-03 15:19
ReporterChristian Mack Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.1.1b 
Target Version2.2.0Fixed in Version2.2.0 
Summary0002565: autocomplete when inviting shows duplicates without free/busy
Description

We use the global address book from LDAP.
Each of these address cards can show you the free/busy info of the corresponding person.

There are only names and email addresses stored in this global address book.
When you need/have more infos about one person, you copy her card into a private address book and add this infos.
But when you invite this person, you now get 2 entries from autocompletion.
One from the global address book with free/busy information and one from your private address book without free/busy information.
In the selection you can not distinguish them. Because of that it is pure luck, if you get free/busy information or not.

You always can confirm that they are equal, because their email addresses are equal.
Please remove duplicates from private address books when autocompleting for invites.

TagsNo tags attached.

Activities

ludovic

ludovic

2014-01-27 15:02

administrator   ~0006437

Is it possible that this only occurs when using Thunderbird?

Christian Mack

Christian Mack

2014-01-29 10:01

developer   ~0006454

I investigated this further.

My initial description was wrong.
Duplicates are only shown, if you have different case in the email address.
Example:
christian.mack@uni-konstanz.de versus Christian.Mack@uni-konstanz.de
This does not happen, if you copy an address card to a private address book.
And per standard the local part of an email address is case sensitive.
So this is done correct by SOGo.
Sorry for that :-(

Different case can happen, when you store your used email addresses from Thunderbird in SOGo, or when you type in an address manually into the address card.

Note:
Thunderbird/Lightning always shows only one address. It seems to be case insensitive on invitations.

ludovic

ludovic

2014-01-29 20:36

administrator   ~0006458

Ok so is there a problem or not?

I just don't understand from your explanation above :-)

Christian Mack

Christian Mack

2014-01-30 05:26

developer   ~0006459

There is a problem for us, as you can not distinguish, which one of the email addresses with different case has free/busy information, and which one doesn't.

I said "for us", as our email addresses do not differ in case.
There are email servers where different case are different mailboxes.
Because of that showing both in the search results is correct.

The solution would be, to mark invitees with free/busy information available in the search result list (eg. other background colour or in bold).
With this the user can choose the one he wants, and knows is the correct mailbox/person.

francis

francis

2014-02-03 15:19

administrator   ~0006473

Fixed.

See https://github.com/inverse-inc/sogo/commit/fcddeb4224308f80184000ad34add7ffc3dcf3c2

Issue History

Date Modified Username Field Change
2013-12-20 07:37 Christian Mack New Issue
2014-01-21 11:52 ludovic Target Version => 2.2.0
2014-01-27 15:02 ludovic Note Added: 0006437
2014-01-29 10:01 Christian Mack Note Added: 0006454
2014-01-29 20:36 ludovic Note Added: 0006458
2014-01-30 05:26 Christian Mack Note Added: 0006459
2014-02-03 15:19 francis Note Added: 0006473
2014-02-03 15:19 francis Status new => resolved
2014-02-03 15:19 francis Fixed in Version => 2.2.0
2014-02-03 15:19 francis Resolution open => fixed
2014-02-03 15:19 francis Assigned To => francis