View Issue Details

IDProjectCategoryView StatusLast Update
0002516SOGoBackend Calendarpublic2014-02-04 17:57
Reportermayak Assigned Tofrancis  
PriorityhighSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
PlatformIntelOSCentos x64OS Version6.4
Product Version2.1.1a 
Target Version2.2.0Fixed in Version2.2.0 
Summary0002516: Auto create of mysql calendar table fails with mysql: 5.6.10 and 5.6.14
Description

tcp dump between sogod and mysql 5.6.10 and 5.6.14

CREATE TABLE sogocgubgdla00300bc52d4_quick ( c_name VARCHAR(255) NOT
NULL PRIMARY KEY, c_uid VARCHAR(255) NOT NULL, c_startdate INT NULL,
c_enddate INT NULL, c_cycleenddate INT NULL, c_title VARCHAR(1000) NOT
NULL, c_participants VARCHAR(1000000) NULL, c_isallday INT NULL,
c_iscycle INT NULL, c_cycleinfo VARCHAR(1000000) NULL,
c_classification INT NOT NULL, c_isopaque INT NOT NULL, c_status INT
NOT NULL, c_priority INT NULL, c_location VARCHAR(255) NULL,
c_orgmail VARCHAR(255) NULL, c_partmails VARCHAR(100000) NULL,
c_partstates VARCHAR(255) NULL, c_category VARCHAR(255) NULL,
c_sequence INT NULL, c_component VARCHAR(10) NOT NULL, c_nextalarm INT
NULL
);

and mysql responds with

ERROR 1074 (42000): Column length too big for column 'c_participants'
(max = 65535); use BLOB or TEXT instead

and that seems to be true:

c_participants VARCHAR(1000000)

where mysql doc show that varchar max length is 65535

Steps To Reproduce

install mysql 5.6.10 -> 5.6.14
install sogo
create new user
login

Additional Information

thanks. sogo is too cool.

TagsNo tags attached.

Issue History

Date Modified Username Field Change
2013-11-26 07:35 mayak New Issue
2014-02-03 19:11 ludovic Target Version => 2.2.0
2014-02-04 17:57 francis Note Added: 0006499
2014-02-04 17:57 francis Status new => resolved
2014-02-04 17:57 francis Fixed in Version => 2.2.0
2014-02-04 17:57 francis Resolution open => fixed
2014-02-04 17:57 francis Assigned To => francis