View Issue Details

IDProjectCategoryView StatusLast Update
0002511SOGoApple iPhone OSpublic2017-05-30 15:50
ReporterBenoit Locher Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformiPhones and iPadsOSIOSOS Version7.0.4
Product Version2.1.1 
Fixed in Version3.2.10 
Summary0002511: r letter appended to every item: names, numbers, etc
Description

When syncing contacts via CardDAV on iPhones and iPads, every item gets a letter 'r' appended to it. It occurs on names, numbers, etc.

See screenshot for example.

Steps To Reproduce

Sync contacts with iPhone/iPad from SOGo v2.1.1 running on Debian, browse contacts from client using the "Contacts" native application.

TagsNo tags attached.

Relationships

duplicate of 0002281 resolvedludovic "\r" in Vcard after import from LDIF 

Activities

Benoit Locher

Benoit Locher

2013-11-24 12:47

reporter  

cdbug1.jpg (39,226 bytes)   
cdbug1.jpg (39,226 bytes)   
Benoit Locher

Benoit Locher

2013-11-24 12:47

reporter  

cdbug2.jpg (32,335 bytes)   
cdbug2.jpg (32,335 bytes)   
Benoit Locher

Benoit Locher

2013-11-24 13:20

reporter   ~0006258

Last edited: 2013-11-24 13:22

View 2 revisions

I add the versions of the involved components in case it can help:

server: Debian Jessie/sid
sogo 2.1.1a-1
mysql-server 5.5.33+dfsg-1
apache 2.4.6-3

Mysql database: InnoDB with utf8_general_ci interclassment.

Christian Mack

Christian Mack

2013-11-25 09:04

developer   ~0006275

iOS Versions?

Benoit Locher

Benoit Locher

2013-11-25 09:08

reporter   ~0006276

Last edited: 2013-11-25 09:12

View 3 revisions

iOS is version 7.0.4 in all cases.

Information was already filled-in under OS Version, but maybe this field was aimed at server version running SOGo? Sorry for the confusion.

Benoit Locher

Benoit Locher

2013-12-14 06:14

reporter   ~0006360

Last edited: 2013-12-14 06:16

View 2 revisions

I edited all my contacts field by field to remove the appended 'r' and they seem to remain clean (without the parasitic 'r' at the end of each field.

Creating a new contact from the SOGo web interface generates a clean contact from iPhone/iPad point of view, without 'r'.

My guess: I suspect this is due to the initial ldif import procedure?

Anyway this ticket severity can be lowered to 'minor' as I could edit and correct each contact (was done on the iPad directly, and with patience)

Christian Mack

Christian Mack

2013-12-16 02:59

developer   ~0006362

Could it be, that your ldif file uses windows line breaks (cr lf)?

If yes, could you try to change them to Unix/Linux line breaks (lf) (e.g. with dos2unix) and test again?

Benoit Locher

Benoit Locher

2013-12-16 03:03

reporter   ~0006363

I will try this and report back. Maybe some '\r' be converted to 'r' for some reasons?

If I remember correctly, the ldif was created under debian from an export made with davical.

Benoit Locher

Benoit Locher

2013-12-17 13:29

reporter   ~0006367

Last edited: 2013-12-18 09:50

View 4 revisions

Now I remember what I did exactly: I exported my old davical address book from Thunderbird address book through the SOGo Connector (v24) as an LDIF file.

(Under Debian I had VCARD format actually, which I didn't use).

So opening this file with Notepad++ and showing all symbols reveals CR LF at the end of each item.

I'm now 99% confident that the appended 'r' come from this steps.

See attached extract of LDIF as viewed in Notepad++.

After this, I simply imported the LDIF back into the SOGo address book using the web interface and "Importer des contacts" context menu on the Address book entry.

I will perform an import test with a test environment to try the import with and without CR/LF. Will report back.

Benoit Locher

Benoit Locher

2013-12-17 13:30

reporter  

sogoldifexport.jpg (33,074 bytes)   
sogoldifexport.jpg (33,074 bytes)   
Benoit Locher

Benoit Locher

2013-12-23 13:09

reporter   ~0006372

Last edited: 2013-12-24 02:17

View 5 revisions

Did the following tests on a newly created address book using the SOGo web interface for one of my users. Software components used:

  • Thunderbird 24.2.0
  • Inverse SOGo Connector 24.0.2

1st test:

  • Exported (ldif) contacts from current address book using SOGo connector + Thunderbird, and kept one contact from the ldif
  • Imported ldif file into new address book: parasitic 'r' were present.

2nd test:

  • Exported (ldif) contacts from current address book using SOGo connector + Thunderbird, and kept one contact
  • Converted each CR+LF into LF using Notepad++ and saved the file
  • Imported converted ldif file into new address book: entry was OK, no more parasitic 'r'.

This confirms the suspicion!

Additional information: the entries with the parasitic 'r' were displayed correctly under Thunderbird address book and in SOGo web interface. The 'r' were only showing up on iPad/iPhone devices.

ludovic

ludovic

2014-02-07 09:08

administrator   ~0006522

Can you retry with the nightly build of SOGo?

I can't reproduce the error.

Benoit Locher

Benoit Locher

2014-02-08 07:27

reporter   ~0006537

Last edited: 2014-02-08 09:22

View 3 revisions

After updating to SOGo 2.1.1b-1 my setup got broken, I get:

object not found: SOGo => index

From web interface :-(

I purged all files from sogo packages (Debian), reinstalled 2.1.1b-1 but still the same. I notice WebServerResources is missing in folder /usr/lib/GNUstep/SOGo

I'll try to fix this and revert for the test you proposed.


Ok, so I switched over to the nightly build 2.1.2.20140208-1.

I exported my current address book from Thunderbird to a .ldif file, created a new calendar in my SOGo account, and imported the contacts.

From my iPhone, I still see the parasitic 'r' (they do not show up on the web interface)

Benoit Locher

Benoit Locher

2014-02-13 01:04

reporter   ~0006544

Did another test: updated my SOGo connector to 24.0.4 fetched today (sogo-connector-24.0.4-6c8ee8bcc2.xpi). Exported the contacts from Thunderbird 24.3.0 and tried to import the ldif filr from SOGo web interface.

The same happens: parasitic r seen on iPhone on this new address book.

Benoit Locher

Benoit Locher

2014-02-26 08:17

reporter   ~0006571

Hi,

For information, I just tested with newly released SOGo v2.2.0-1 (debian) and problem still exists.

Best Regards,

BenoƮt.

Christian Mack

Christian Mack

2014-07-25 11:01

developer   ~0007352

Just got an report of this bug again with 2.2.4.
And tested it with nightlies.

You need an LDIF file with <CR><LF> line endings instead of the <LF> ones (I made a one with unix2dos).
Import that into SOGo, then synchronize with iPhone/iPad.

Benoit Locher

Benoit Locher

2014-07-25 11:19

reporter   ~0007353

Last edited: 2014-07-25 11:49

View 4 revisions

Actually, this is the opposite: importing an LDIF file with <CR><LF> will cause the parasitic 'r' to appear on iPhones/iPads (as stated in 0002511:0006372 ).

I just did the test again: exporting a SOGo address book to an LDIF text file, it has <CR><LF> line terminations. Importing this file into SOGo web interface will cause the 'r' to be appended on each entry.

Converting the LDIF file from <CR><LF> to <LF> before importing into SOGo clears the problem out.

Christian Mack

Christian Mack

2014-07-25 11:43

developer   ~0007354

Sorry, I should have said:
In order to reproduce this bug you need ....

Benoit Locher

Benoit Locher

2014-07-25 12:32

reporter   ~0007356

Yes, exacly. This is not a big problem per se when you know the cause anyway.

ludovic

ludovic

2017-05-30 15:50

administrator   ~0011886

https://github.com/inverse-inc/sogo/commit/29dfc75fe94ddbbae012d729eb2d020b953dac27

Issue History

Date Modified Username Field Change
2013-11-24 12:38 Benoit Locher New Issue
2013-11-24 12:47 Benoit Locher File Added: cdbug1.jpg
2013-11-24 12:47 Benoit Locher File Added: cdbug2.jpg
2013-11-24 13:20 Benoit Locher Note Added: 0006258
2013-11-24 13:22 Benoit Locher Note Edited: 0006258 View Revisions
2013-11-25 09:04 Christian Mack Note Added: 0006275
2013-11-25 09:08 Benoit Locher Note Added: 0006276
2013-11-25 09:12 Benoit Locher Note Edited: 0006276 View Revisions
2013-11-25 09:12 Benoit Locher Note Edited: 0006276 View Revisions
2013-12-14 06:14 Benoit Locher Note Added: 0006360
2013-12-14 06:16 Benoit Locher Note Edited: 0006360 View Revisions
2013-12-16 02:59 Christian Mack Note Added: 0006362
2013-12-16 03:03 Benoit Locher Note Added: 0006363
2013-12-17 13:29 Benoit Locher Note Added: 0006367
2013-12-17 13:30 Benoit Locher File Added: sogoldifexport.jpg
2013-12-17 13:31 Benoit Locher Note Edited: 0006367 View Revisions
2013-12-17 13:33 Benoit Locher Note Edited: 0006367 View Revisions
2013-12-18 09:50 Benoit Locher Note Edited: 0006367 View Revisions
2013-12-23 13:09 Benoit Locher Note Added: 0006372
2013-12-24 02:12 Benoit Locher Note Edited: 0006372 View Revisions
2013-12-24 02:13 Benoit Locher Note Edited: 0006372 View Revisions
2013-12-24 02:15 Benoit Locher Note Edited: 0006372 View Revisions
2013-12-24 02:17 Benoit Locher Note Edited: 0006372 View Revisions
2014-02-07 09:08 ludovic Note Added: 0006522
2014-02-07 09:08 ludovic Severity block => minor
2014-02-08 07:27 Benoit Locher Note Added: 0006537
2014-02-08 09:21 Benoit Locher Note Edited: 0006537 View Revisions
2014-02-08 09:22 Benoit Locher Note Edited: 0006537 View Revisions
2014-02-13 01:04 Benoit Locher Note Added: 0006544
2014-02-26 08:17 Benoit Locher Note Added: 0006571
2014-07-25 10:29 Christian Mack Relationship added duplicate of 0002281
2014-07-25 11:01 Christian Mack Note Added: 0007352
2014-07-25 11:19 Benoit Locher Note Added: 0007353
2014-07-25 11:43 Christian Mack Note Added: 0007354
2014-07-25 11:44 Christian Mack Note Edited: 0007353 View Revisions
2014-07-25 11:45 Christian Mack Note Edited: 0007353 View Revisions
2014-07-25 11:49 Christian Mack Note Edited: 0007353 View Revisions
2014-07-25 12:32 Benoit Locher Note Added: 0007356
2017-05-30 15:50 ludovic Note Added: 0011886
2017-05-30 15:50 ludovic Status new => resolved
2017-05-30 15:50 ludovic Fixed in Version => 3.2.10
2017-05-30 15:50 ludovic Resolution open => fixed
2017-05-30 15:50 ludovic Assigned To => ludovic