View Issue Details

IDProjectCategoryView StatusLast Update
0002504SOGoWeb Mailpublic2013-11-22 14:51
Reportercnaumer Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.1.1 
Fixed in Version2.1.1a 
Summary0002504: can not change/add sieves rules in "prefences"
Description

After the upgrade to 2.1.1 sieves rules can not be added or modified in "prefences"-dialog
The fields of the filter box are empty after you click on the filter.

Steps To Reproduce

Click on + to add new filter. Click again on + to add new rule. Nothing happens.
If you click on an already existing Filter the next window is empty

TagsNo tags attached.

Activities

jraby

jraby

2013-11-21 06:54

viewer   ~0006247

Last edited: 2013-11-21 06:56

View 2 revisions

It is a java script error : <pre> Uncaught SyntaxError: Unexpected token & </pre>

It is probably caused by html entities in the var labels declaration (editFilter:37)

<pre>
<script type="text/javascript">
var filterId = 'new';
var labels = {"$label1": ["Important", "#FF0000"], "$label2": ["Work", "#FF9900"], "$label3": ["Personal", "#009900"], "$label4": ["To Do", "#3333FF"], "$label5": ["Later", "#993399"]};
</script>
</pre>

jraby

jraby

2013-11-21 07:12

viewer   ~0006248

Last edited: 2013-11-21 08:59

View 2 revisions

can you apply this patch https://github.com/inverse-inc/sogo/commit/682ed767d956f0650de36e352ff3285856fdc0b3 and see if it works for you?

Issue History

Date Modified Username Field Change
2013-11-21 06:43 cnaumer New Issue
2013-11-21 06:54 jraby Note Added: 0006247
2013-11-21 06:56 jraby Note Edited: 0006247 View Revisions
2013-11-21 07:12 jraby Note Added: 0006248
2013-11-21 08:59 francis Note Edited: 0006248 View Revisions
2013-11-21 08:59 francis Status new => resolved
2013-11-21 08:59 francis Fixed in Version => 2.2.0
2013-11-21 08:59 francis Resolution open => fixed
2013-11-21 08:59 francis Assigned To => francis
2013-11-22 14:51 francis Fixed in Version 2.2.0 => 2.1.1a