View Issue Details

IDProjectCategoryView StatusLast Update
0002481SOGoWeb Mailpublic2014-02-18 15:39
Reporterjoromindlab Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.0.7 
Fixed in Version2.2.0 
Summary0002481: Webmailer loses content from body when forwarding
Description

I was trying to forward an email from a fail2ban-daemon to another account. However strings in the form <name.surname> were parsed out and replaced by an empty string, rendering the mail useless.

The web frontend seems to kill anything that looks "markup-ish"

Steps To Reproduce

send mail to a sogo account with body like this:

some_word <markup.string> other_word

receive this mail in sogo and forward it from there. The forwarded mail (in the compose window and also on the receipients end) will be:

-------- Original-Message--------
Betreff: Fwd: bla
Datum: Dienstag, 05. November 2013 09:12 CET
Von: "John Doe" <john.doe@domain.de>
An: user@otherdomain.de

some_word other_word

Additional Information

Header info doesn't get parsed out, only body
no relevant log entries are recorded, so this seems to hit before anything is logged
Using different browsers (tried chrome, firefox, ie) does not make any difference

TagsNo tags attached.

Relationships

duplicate of 0002411 resolvedfrancis Inline forwarding can truncate text from original message 

Activities

dani

dani

2013-11-05 03:53

reporter   ~0006201

This is a dup of Bug 0002411

Issue History

Date Modified Username Field Change
2013-11-05 03:27 joromindlab New Issue
2013-11-05 03:53 dani Note Added: 0006201
2014-02-18 15:39 francis Relationship added duplicate of 0002411
2014-02-18 15:39 francis Status new => resolved
2014-02-18 15:39 francis Fixed in Version => 2.2.0
2014-02-18 15:39 francis Resolution open => fixed
2014-02-18 15:39 francis Assigned To => francis