View Issue Details

IDProjectCategoryView StatusLast Update
0002450SOGoPackaging (Debian)public2013-10-15 08:44
Reporterprauscher Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformLinuxOSDebianOS Version7.0
Product Version2.0.7 
Summary0002450: /etc/cron.daily/sogo exits non-zero if /var/spool/sogo is non-empty
Description

The current cleanup-cron-script contains
find "$SOGOSPOOL" -mindepth 1 -type d -empty -exec /bin/rmdir {} \; 2> /dev/null

find will try to read the contents of a found directory after it has been removed by rmdir. This can be fixed by adding -depth to finds arguments. The Error-redirection can then safely deleted.

While it exits with exitcode 1, it triggers an errormessage which will be mailed to the admin. This daily message is annoying.

Steps To Reproduce
  1. Add Packagesource deb http://inverse.ca/debian wheezy wheezy
  2. Install sogo
  3. Wait for the cron to executed while /var/spool/sogo is non-empty
TagsNo tags attached.

Relationships

duplicate of 0002372 resolvedjraby /etc/cron.daily/sogo exited with return code 1 with Ubuntu package 

Activities

heupink

heupink

2013-10-15 04:33

reporter   ~0006102

Is this perhaps related to issue no 0002372?

prauscher

prauscher

2013-10-15 05:38

reporter   ~0006103

Yes. Sorry, did not find this bug when I searched the Bugtracker. This can safely marked as duplicate.

heupink

heupink

2013-10-15 07:44

reporter   ~0006104

But: that bug is resolved. (however, perhaps not yet in 2.0.7?

We don't see the issue anymore, but I applied the fix manually, and perhaps it only arrives automatically in 2.0.8?

Issue History

Date Modified Username Field Change
2013-10-14 12:20 prauscher New Issue
2013-10-15 04:33 heupink Note Added: 0006102
2013-10-15 05:38 prauscher Note Added: 0006103
2013-10-15 07:44 heupink Note Added: 0006104
2013-10-15 08:44 francis Relationship added duplicate of 0002372
2013-10-15 08:44 francis Status new => closed
2013-10-15 08:44 francis Assigned To => francis
2013-10-15 08:44 francis Resolution open => duplicate