View Issue Details

IDProjectCategoryView StatusLast Update
0002417SOGoWeb Mailpublic2013-09-13 11:08
Reporterfourstone Assigned Tofrancis  
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.0.7 
Target Version2.1.0Fixed in Version2.1.0 
Summary0002417: In Preview Pane external pictures are ALWAYS loaded, when opening by doubleclicking --> load pictures
Description

Hello,

I did not find any mention of this issue anywhere, so here goes:

If I click on any email in the inbox which loads external pictures, then these external pictures are always shown.
If I doubleclick on the very same message and is shown in a new window, I have to click on "load pictures" first.

I am fine with both behaviors, BUT:
I would have both methods behave the same way, i.e. NOT show the pictures in preview AND not show the pictures when doubleclicking.

The other is also fine: Always show all pictures.

Best would be a general switch to ask or not ask for picture load authorization.
Maybe there already is, however I and the hoster of the SOGO solution cannot find it.

To me this is an issue because spammers will gather information when their pictures get loaded.

kind regards, Martin

TagsNo tags attached.

Activities

francis

francis

2013-09-12 17:10

administrator   ~0005990

Fixed.

See https://github.com/inverse-inc/sogo/commit/72a4b075d6201baa438462937420fcef4c677f23

fourstone

fourstone

2013-09-12 17:17

reporter   ~0005991

Hello Francis,

as far as I understand your fix, it only cares about obeying the setting for the popupwindow.

What about the previewpane?

Or did I get something wrong?

Kind regards, Martin

francis

francis

2013-09-12 17:26

administrator   ~0005992

The preview pane was already correct.

The only remaining bug is that the main view should be reloaded when the preferences for the remote inline images is changed.

francis

francis

2013-09-13 09:38

administrator   ~0005996

Web interface will now be reloaded when changing the "load remote images" preference.

See https://github.com/inverse-inc/sogo/commit/3c6c90d4346ce19e3245466d22ee3f659c1ac8e9

Issue History

Date Modified Username Field Change
2013-09-12 09:12 fourstone New Issue
2013-09-12 09:17 francis Target Version => 2.1.0
2013-09-12 17:10 francis Note Added: 0005990
2013-09-12 17:10 francis Status new => resolved
2013-09-12 17:10 francis Fixed in Version => 2.1.0
2013-09-12 17:10 francis Resolution open => fixed
2013-09-12 17:10 francis Assigned To => francis
2013-09-12 17:17 fourstone Note Added: 0005991
2013-09-12 17:17 fourstone Status resolved => feedback
2013-09-12 17:17 fourstone Resolution fixed => reopened
2013-09-12 17:26 francis Note Added: 0005992
2013-09-13 09:38 francis Note Added: 0005996
2013-09-13 11:08 francis Status feedback => resolved
2013-09-13 11:08 francis Resolution reopened => fixed