View Issue Details

IDProjectCategoryView StatusLast Update
0002399SOGoBackend Calendarpublic2013-09-25 16:04
ReporterMarten Gajda Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version2.0.7 
Target Version2.1.0Fixed in Version2.1.0 
Summary0002399: DAV:resource-id does not equal for bound resources
Description

When sharing a calendar with another user the calendar can be found either as bound resource or via calendar-proxy-(read|write)-for.

If I understand http://tools.ietf.org/html/rfc5842#section-3.1 correctly, the property DAV:resource-id is to identify if the two resources are the same.

I've shared sogo1's calendar 'Public' with sogo2. Using the credentials of sogo2 it's accessible via /SOGo/dav/sogo1/Calendar/217D-52127080-19-613AAD00/ and /SOGo/dav/sogo2/Calendar/sogo1_217D-52127080-19-613AAD00/

If I send this request to both calendars:

<?xml version="1.0" encoding="UTF-8"?>
<A:propfind xmlns:A="DAV:">
<A:prop>
<A:resource-id />
<A:displayname />
</A:prop>
</A:propfind>

with "depth:0" I get:

<?xml version="1.0" encoding="utf-8"?>
<D:multistatus xmlns:D="DAV:">
<D:response>
<D:href>/SOGo/dav/sogo1/Calendar/217D-52127080-19-613AAD00/</D:href>
<D:propstat>
<D:status>HTTP/1.1 200 OK</D:status>
<D:prop>
<D:resource-id>urn:uuid:sogo1:calendars:217D-52127080-19-613AAD00</D:resource-id>
<D:displayname>Public (John Doe <sogo1@sogo-demo.inverse.ca>)</D:displayname>
</D:prop>
</D:propstat>
</D:response>
</D:multistatus>

and

<?xml version="1.0" encoding="utf-8"?>
<D:multistatus xmlns:D="DAV:">
<D:response>
<D:href>/SOGo/dav/sogo2/Calendar/sogo1_217D-52127080-19-613AAD00/</D:href>
<D:propstat>
<D:status>HTTP/1.1 200 OK</D:status>
<D:prop>
<D:resource-id>urn:uuid:sogo1:calendars:sogo1_217D-52127080-19-613AAD00</D:resource-id>
<D:displayname>Public (John Doe <sogo1@sogo-demo.inverse.ca>)</D:displayname>
</D:prop>
</D:propstat>
</D:response>
</D:multistatus>

Since the resource-id doesn't equal ("urn:uuid:sogo1:calendars:217D-52127080-19-613AAD00" vs. "urn:uuid:sogo1:calendars:sogo1_217D-52127080-19-613AAD00") there is no way to tell for a client that both calendars are the same, or did I miss something?

TagsNo tags attached.

Activities

ludovic

ludovic

2013-09-25 16:04

administrator   ~0006040

Fixed: https://github.com/inverse-inc/sogo/commit/7166f5a597035e376517a27c56579ff0ae0ae985

Test with sogo-demo.inverse.ca.

Issue History

Date Modified Username Field Change
2013-08-24 07:18 Marten Gajda New Issue
2013-09-25 16:02 ludovic Target Version => 2.1.0
2013-09-25 16:02 ludovic Description Updated
2013-09-25 16:04 ludovic Note Added: 0006040
2013-09-25 16:04 ludovic Status new => closed
2013-09-25 16:04 ludovic Resolution open => fixed
2013-09-25 16:04 ludovic Fixed in Version => 2.1.0