View Issue Details

IDProjectCategoryView StatusLast Update
0002326SOGoBackend Calendarpublic2014-09-15 09:33
Reporteraminet Assigned Toludovic  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
PlatformApple 
Product Version2.0.5 
Target Version2.2.9Fixed in Version2.2.9 
Summary0002326: Some caldav client doesn't set privacy setting a default one could be great
Description

Some caldav clients, including those from Apple (iphone / ical.app) doesn't create VEVENT with a CLASS.

The event ends up as "public" in SOGo.
Technicaly and more precisely in the column c_classification of table "sogoLOGINcadID_quick" is set to 0 (1 is public, 2 confidential and 3 private).

It would be great if:

  • in the calendar properties a default privacy level could be set: public, confidential, private and none (don't do anything).
  • in sogo.conf a global default value for privacy level of new calendars could be set

Regards

Steps To Reproduce

All events created from an iOS or iCal.app haven't any class or privacy level set.
It's default in SOGo to public from the point of view of the user to whom corresponding calendar was shared.

TagsNo tags attached.

Activities

jraby

jraby

2013-05-15 12:54

viewer   ~0005593

Can you test with this preference set and see if it behaves correctly?
<pre>
SOGoCalendarEventsDefaultClassification Parameter used to defined the default classification for new events. Possible values are :

  • PUBLIC
  • CONFIDENTIAL
  • PRIVATE

Defaults to PUBLIC when unset.
</pre>

You will have to set it for your existing users, either via the preference dialog, or via sogo-tool.

aminet

aminet

2013-05-16 09:12

reporter   ~0005600

In our configuration we have:
SOGoCalendarEventsDefaultClassification = CONFIDENTIAL;
SOGoCalendarTasksDefaultClassification = CONFIDENTIAL;

So each user have in his preferences in SOGo Web interface under Calendar Options:
Default events classification: Confidential
Default tasks classification: Confidential

and when creating a new event in SOGo Web interface or in Thunderbird with SOGO-Connector/Integrator the button "Privacy" is set to Confidential (or in Thunderbird to "Show Time and Date only' due to a lightning bug: 649944)

But the problem is with other clients, connecting to SOGo through Caldav, which didn't set the CLASS of the event. For example:

BEGIN:VCALENDAR
PRODID:-//Apple Inc.//iCal 4.0.4//EN
VERSION:2.0
CALSCALE:GREGORIAN
BEGIN:VTIMEZONE
TZID:Europe/Paris
BEGIN:DAYLIGHT
TZOFFSETFROM:+0100
RRULE:FREQ=YEARLY;BYMONTH=3;BYDAY=-1SU
DTSTART:19810329T020000
TZNAME:GMT+02:00
TZOFFSETTO:+0200
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0200
RRULE:FREQ=YEARLY;BYMONTH=10;BYDAY=-1SU
DTSTART:19961027T030000
TZNAME:GMT+01:00
TZOFFSETTO:+0100
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20130516T124634Z
UID:1E1DB0A9-FFE6-4B9A-9ED3-66FF23E88527
DTEND;TZID=Europe/Paris:20130426T070000
TRANSP:OPAQUE
SUMMARY:test ical
DTSTART;TZID=Europe/Paris:20130425T150000
DTSTAMP:20130516T124746Z
LOCATION:ici et la
SEQUENCE:6
END:VEVENT
END:VCALENDAR
(extract from the url /SOGo/so/login/Calendar/calid/eventid.ics/raw)

in the VEVENT CLASS:CONFIDENTIAL (or PUBLIC/PRIVATE) is missing.

As a result for this event the corresponding line in the database have c_classification set to 0 (not 1 2 or 3), it is like not set.
For the final users who have access to the shared calendar they see the event as if it was public, as it has no privacy level set.
The new feature is about having a default privacy level for new event created through caldav, it is at backend level.

As I understand SOGoCalendarEventsDefaultClassification only affect frontend (SOGo web + connector/integrator) but not the backend.

Regards

ludovic

ludovic

2014-09-15 09:33

administrator   ~0007510

https://github.com/inverse-inc/sogo/commit/02b3de6465c85e254f265cedb28a0e96aeef6f31

Issue History

Date Modified Username Field Change
2013-05-15 11:52 aminet New Issue
2013-05-15 12:54 jraby Note Added: 0005593
2013-05-15 12:55 jraby Status new => feedback
2013-05-16 09:12 aminet Note Added: 0005600
2014-09-12 11:34 ludovic Target Version => 2.2.9
2014-09-15 09:33 ludovic Note Added: 0007510
2014-09-15 09:33 ludovic Status feedback => closed
2014-09-15 09:33 ludovic Assigned To => ludovic
2014-09-15 09:33 ludovic Resolution open => fixed
2014-09-15 09:33 ludovic Fixed in Version => 2.2.9