View Issue Details

IDProjectCategoryView StatusLast Update
0002224SOGoWeb Calendarpublic2013-02-04 05:48
Reporterwimmer Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.0.4a 
Fixed in Version2.0.4b 
Summary0002224: Setting of Access rights for Any Authenticated User
Description

Setting of access rules of calendar for "Any Authenticated User" causes error in WebGUI.
In the dialog window I see:
An error occurred during object publishing
No such user.

and in the sogo.log I see:
localhost - - [01/Feb/2013:00:00:13 GMT] "GET /SOGo/so/harryp/Calendar/personal/userRights?uid= HTTP/1.1" 403 181/0 0.021 - - 12K

No problem by setting rules for "Public Access", no problem for selected users.
I have no problem with this in Lightning.
And I have no problems when I roll back to 2.0.3a.

I found the same problem on all my 3 servers (Debian64 Wheezy with SOGo compiled from sources and installed from packages too). It works fine on Demo http://sogo-demo.inverse.ca on SOGo 2.0.4.

TagsNo tags attached.

Activities

wimmer

wimmer

2013-02-01 10:02

reporter   ~0005310

duplicate of 0002222

ok, but FYI - it was/is hidden for me.
http://www.sogo.nu/bugs/view.php?id=2222 gives "Access Denied."

Christian Mack

Christian Mack

2013-02-04 05:47

developer   ~0005322

You are right, bug #2222 is set private.

It is fixed now by francis:
See https://github.com/inverse-inc/sogo/commit/716daf027de29bc72ffb84368291c191c49fa1e2

Issue History

Date Modified Username Field Change
2013-01-31 19:39 wimmer New Issue
2013-02-01 10:02 wimmer Note Added: 0005310
2013-02-04 05:47 Christian Mack Note Added: 0005322
2013-02-04 05:48 Christian Mack Status new => resolved
2013-02-04 05:48 Christian Mack Resolution open => fixed
2013-02-04 05:48 Christian Mack Fixed in Version => 2.0.5