View Issue Details

IDProjectCategoryView StatusLast Update
0002208SOGoBackend Generalpublic2013-02-05 14:41
Reporterzadir Assigned Tojraby 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSDebianOS Version5 (Lenny)
Product Version2.0.4 
Summary0002208: LDAP Authentication for users with accent in any part of DN
Description

Sogo fail to bind to ldap with a DN that has accent on it.
I belive that the cause is the encoded UTF-8 chars in the bind string:

Jan 29 22:57:22 sogod [5530]: <0x0x7f8b7cd27c50[LDAPSource]> <NSException: 0x7f8b7d3c6dd0> NAME:LDAPException REASON:operation bind failed: Invalid credentials (0x31) INFO:{login = "cn=jos\C3\A9 zadir ferreira neto,ou=serba,ou=cosup,ou=sti,ou=tribunal,dc=tre-rs,dc=gov,dc=br"; }

the login should be "cn=José Zadir....."

Steps To Reproduce

Just change the cn of any user on ldap to include an accent. restart sogo and try to login.

Tagsactive-directory, ldap

Relationships

duplicate of 0002207 resolvedjraby LDAP Authentication for users in OU with accent 

Activities

roms

roms

2013-01-30 03:25

reporter   ~0005275

same as mine http://www.sogo.nu/bugs/view.php?id=2207

jraby

jraby

2013-01-30 14:02

viewer   ~0005285

Do you use active directory as the LDAP backend?

jraby

jraby

2013-01-30 14:50

viewer   ~0005286

Ok, forget it, I reproduced to problem here with AD

Issue History

Date Modified Username Field Change
2013-01-29 20:13 zadir New Issue
2013-01-29 21:31 zadir Tag Attached: active-directory
2013-01-29 21:32 zadir Tag Attached: ldap
2013-01-30 03:25 roms Note Added: 0005275
2013-01-30 09:14 Christian Mack Relationship added duplicate of 0002207
2013-01-30 14:02 jraby Note Added: 0005285
2013-01-30 14:50 jraby Note Added: 0005286
2013-02-05 14:41 jraby Assigned To => jraby
2013-02-05 14:41 jraby Status new => resolved
2013-02-05 14:41 jraby Resolution open => fixed