View Issue Details

IDProjectCategoryView StatusLast Update
0002187SOGoBackend Address Bookpublic2014-01-31 15:05
ReporterChristian Mack Assigned Toludovic  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.3a 
Target Version2.2.0Fixed in Version2.2.0 
Summary0002187: Simplyfy searches and autocompletion
Description

Here in germany we have a lot of people with double surnames.
They can be chosen on marrige, or after adoption.
Basically someone can initially have surname "Vorfelder" and change it on marrige with someone with surname "Mayer" to "Mayer-Vorfelder" or "Vorfelder-Mayer".

When someone has known this person before the change of the surname, she will search for the old known surname by typing "Vorfelder".
But if the surname has changed to "Mayer-Vorfelder" she will not get a result.
So she has to know that the name has changed and has to search for "*Vorfelder".
From the view of the user this is not intuitive.

Therefore the default search should always search for substrings (== "${PATTERN}") in LDAP or DB fields.
This is especially true for autocompletion too.

TagsNo tags attached.

Activities

ludovic

ludovic

2014-01-27 14:52

administrator   ~0006436

Try this patch:

--- a/SoObjects/SOGo/LDAPSource.m
+++ b/SoObjects/SOGo/LDAPSource.m
@@ -717,7 +717,7 @@ static Class NSStringK;
[qs appendFormat: @"(%@='*')", CNField];
else
{

  • fieldFormat = [NSString stringWithFormat: @"(%%@='%@*')", escapedFilter];
  • fieldFormat = [NSString stringWithFormat: @"(%%@='%@')", escapedFilter];
    fields = [NSMutableArray arrayWithArray: searchFields];
    [fields addObjectsFromArray: mailFields];
    [fields addObject: CNField];

For GCS folders (database), it looks like it's already ok.

ludovic

ludovic

2014-01-31 15:05

administrator   ~0006463

https://github.com/inverse-inc/sogo/commit/ddd7be433346fce2d1f6c6ed52ead56c1f289f41

Issue History

Date Modified Username Field Change
2013-01-18 04:26 Christian Mack New Issue
2013-01-18 10:21 ludovic Target Version => soon
2014-01-21 11:52 ludovic Target Version soon => 2.2.0
2014-01-27 14:52 ludovic Note Added: 0006436
2014-01-31 15:05 ludovic Note Added: 0006463
2014-01-31 15:05 ludovic Status new => closed
2014-01-31 15:05 ludovic Assigned To => ludovic
2014-01-31 15:05 ludovic Resolution open => fixed
2014-01-31 15:05 ludovic Fixed in Version => 2.2.0