View Issue Details

IDProjectCategoryView StatusLast Update
0000218SOGoWeb Mailpublic2010-09-16 14:16
Reporterdlak Assigned Towsourdeau 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.1.0 
Fixed in Version1.3.2 
Summary0000218: When an SMTP error occurs, SOGo should display a nice error message, rather than crashing abruptly
Description

Sogod crashes when recieving an smtp error, like "550 recipient addres rejected".

The webui should report the error(popup) instead of giving a 502 proxy error.

If the user makes a typo (wrong recipient address), or the smtp server rejects the message for some reason, it leads to the same issue.

Additional Information

Nov 02 12:48:05 sogod [21628]: <0x0x31a7fc0[SOGoMailer]> error with recipient 'asf@n.hu'
EXCEPTION: <NSException: 0x329aeb0> NAME:SMTPException REASON:require state 2, now in 3 INFO:(nil)

child 21628 (0000025) was terminated by signal 6 (uptime=239s).

2009-11-02 12:48:05.568 sogod[21715] starting SOGo (build root@vizzini.inverse.ca 200910281643)

TagsNo tags attached.

Relationships

related to 0000559 resolvedwsourdeau Can't send mail via SMTP due to bad address syntax 

Activities

dlak

dlak

2009-11-02 07:49

reporter   ~0000269

The error occures during mail sending....ofcourse

John Bloom

John Bloom

2010-05-18 14:58

reporter   ~0001029

Last edited: 2010-05-18 15:09

This appears to affect iCal (3 and 4) as well. If an iCal user mistakenly misspells the user part of an email address on the same domain as themselves. iCal then responds with:
'The server responded with
“HTTP/1.1 502 Proxy Error”
to operation CalDAVScheduleEventQueueableOperation.'
[ Go Offline ] [ Revert to Server ] [ Go Online ]

iCal can continue to be used if the 'Revert to Server' button is selected. However, after that, the event involving that attendee can't easily be deleted, because iCal's only option for deleting an event is 'Delete and Notify'. When the user clicks 'Delete and Notify', SOGo attempts to send an email to the misspelled email address and that sogod process dies with an SMTPException.
To reproduce this on the demo server:
1) Setup iCal 3 or 4 to connect to it with CalDAV.
2) Create a new event.
3) Attempt to invite: afsdfsf@sogo-demo.inverse.ca
4) Click Send.

chris_hobbs

chris_hobbs

2010-07-14 13:48

reporter   ~0001187

This issue still exists in recent nightly builds. I'm running into this in 1.2.2.20100707 if a user enters an incorrect address on the local domain.

ludovic

ludovic

2010-07-15 21:29

administrator   ~0001191

We'll fix the issue eventually, do not worry.

In the meantime, if you want to avoid the issue, you could set the mailing mechanism to "sendmail" instead of "smtp".

wsourdeau

wsourdeau

2010-08-23 17:12

viewer   ~0001326

This is fixed. The webmail no longer display a livid page and the exception in question is no longer raised.

Issue History

Date Modified Username Field Change
2009-11-02 06:59 dlak New Issue
2009-11-02 07:49 dlak Note Added: 0000269
2010-04-12 07:41 francis Relationship added has duplicate 0000559
2010-04-13 11:59 wsourdeau Relationship replaced related to 0000559
2010-04-13 12:00 wsourdeau Category Backend Mail => Web Mail
2010-04-13 12:00 wsourdeau Summary Sogod crashes on smtp error - SMTPException => When an SMTP error occurs, SOGo should display a nice error message, rather than crashing abruptly
2010-05-18 14:58 John Bloom Note Added: 0001029
2010-05-18 15:09 John Bloom Note Edited: 0001029
2010-07-14 13:48 chris_hobbs Note Added: 0001187
2010-07-15 21:29 ludovic Note Added: 0001191
2010-08-23 17:12 wsourdeau Note Added: 0001326
2010-08-23 17:12 wsourdeau Status new => resolved
2010-08-23 17:12 wsourdeau Fixed in Version => Monotone / nightly
2010-08-23 17:12 wsourdeau Resolution open => fixed
2010-08-23 17:12 wsourdeau Assigned To => wsourdeau
2010-09-16 14:16 francis Fixed in Version Monotone / nightly => 1.3.2