View Issue Details

IDProjectCategoryView StatusLast Update
0002101SOGoBackend Address Bookpublic2012-11-30 11:01
Reportersim Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.2 
Target Version2.0.3Fixed in Version2.0.3 
Summary0002101: Integrator overwrites TB autocompletion directory server selection
Description

The Integrator extension for Thunderbird will overwrite (to blank) the selection in: Options > Composition > Addressing > Directory Server

As soon as Integrator has connected (one can tell because the calendar and address book buttons are visible) the selection becomes blank.

After making a selection and closing Thunderbird, it becomes blank when Integrator connects to SOGo. Before it connects, the selection is still set.

If I disable Integrator, this never happens.

Additional Information

It's very important for users to have auto-completion of their colleagues email addresses.

TagsNo tags attached.

Activities

sim

sim

2012-11-20 21:51

reporter   ~0004944

Not a bug - just lack of documentation. I suggest that in the installation documentation of the Thunderbird extensions that this preference gets mentioned for adjusting or removal:
pref("sogo-integrator.autocomplete.server.urlid", "public");

Removing this line, fixed the issue. I suppose setting it to something may be useful, but not until filters for the SOGoUserSources work. Then SOGo can have a useful address book (http://www.sogo.nu/bugs/view.php?id=2055).

ludovic

ludovic

2012-11-30 11:01

administrator   ~0005004

Fixed with: https://github.com/inverse-inc/sogo/commit/0e02334fda980dccf623d76bebbab997d22de837

Note that you should NOT delete sogo-integrator.autocomplete.server.urlid but rather adjust it to the value of the id in your SOGoUserSources. The documentation reflects that.

Issue History

Date Modified Username Field Change
2012-11-13 01:00 sim New Issue
2012-11-20 21:51 sim Note Added: 0004944
2012-11-21 11:44 ludovic Target Version => 2.0.3
2012-11-30 11:01 ludovic Note Added: 0005004
2012-11-30 11:01 ludovic Status new => closed
2012-11-30 11:01 ludovic Resolution open => fixed
2012-11-30 11:01 ludovic Fixed in Version => 2.0.3