View Issue Details

IDProjectCategoryView StatusLast Update
0002091SOGoWeb Mailpublic2016-12-30 13:57
ReporterFuchur Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.0.0 
Fixed in Version3.2.5 
Summary0002091: Mail header fields not according to rfc2822 section-2.2.3 / 3.6.
Description

We are having issues in some mail-clients with mail header information sent from SOGo Webmail.

We traced it back to the fact that the field headers are NOT starting with a Capital. They start with lowercase which is as far as we can see not according to the RFC.

Next to this our mail is often seen as spam since we use SOGo this might be linked to not keeping to the standards too.

Additional Information

Send from the webclient:

User-Agent: SOGoMail 2.0.0
reply-to:
MIME-Version:
from:
subject:
message-id:
to:
content-type:
date:
content-length:
content-transfer-encoding:
cc:

Should be:

User-Agent: SOGoMail 2.0.0
Reply-to:
MIME-Version:
From:
Subject:
Message-id:
To:
Content-type:
Date:
Content-length:
Content-transfer-encoding:
Cc:

And possibly for other fields...

TagsNo tags attached.

Relationships

has duplicate 0001047 resolvedludovic lowercase-header-files triggers spam filters 

Issue History

Date Modified Username Field Change
2012-11-05 10:13 Fuchur New Issue
2012-11-06 08:10 ludovic Relationship added duplicate of 0001048
2012-11-06 08:10 ludovic Duplicate ID 0 => 1048
2012-11-06 08:10 ludovic Status new => resolved
2012-11-06 08:10 ludovic Resolution open => duplicate
2012-11-06 08:10 ludovic Assigned To => ludovic
2012-11-06 08:10 ludovic Relationship added has duplicate 0001047
2012-11-06 08:10 ludovic Relationship deleted 0001048
2013-12-09 08:46 francis Status resolved => confirmed
2016-12-30 13:57 ludovic Note Added: 0011147
2016-12-30 13:57 ludovic Status confirmed => resolved
2016-12-30 13:57 ludovic Fixed in Version => 3.2.5