View Issue Details

IDProjectCategoryView StatusLast Update
0002012SOGoOpenChange backendpublic2012-10-15 23:17
ReporterwsourdeauAssigned Towsourdeau 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Target Version2.0.2Fixed in Version2.0.2 
Summary0002012: scalability: the fetching/parsing of coreInfos struct takes a long time for a large amount of messages
Description

NGImap4ResponseParser could probably be enhanced somehow. The problem might lie with NGByteStream since the parsing of message bodies is actually fast for those, meaning that the delay occurs when parsing header parts with a lot of small subparts.

TagsNo tags attached.

Activities

wsourdeau

wsourdeau

2012-10-15 23:17

viewer   ~0004665

NGByteBuffer, reducing the speed from 15secs to 3 secs for parsing the coreInfos for 13000 messages.

Issue History

Date Modified Username Field Change
2012-10-07 10:41 wsourdeau New Issue
2012-10-07 10:42 wsourdeau Target Version => 2.0.2
2012-10-15 23:17 wsourdeau Note Added: 0004665
2012-10-15 23:17 wsourdeau Status new => resolved
2012-10-15 23:17 wsourdeau Fixed in Version => 2.0.2
2012-10-15 23:17 wsourdeau Resolution open => fixed
2012-10-15 23:17 wsourdeau Assigned To => wsourdeau