View Issue Details

IDProjectCategoryView StatusLast Update
0001987SOGoWeb Mailpublic2013-08-09 15:49
ReporterJMK Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionsuspended 
Product Version1.3.18 
Summary0001987: Blank page with some kind of mails (_processCommandParserException)
Description

Some of our users have a blank page when going to the webmail. I have the following errors in sogo.log:

[NGImap4Client]> ERROR(-[NGImap4Client _processCommandParserException:]): catched IMAP4 parser exception NGImap4ParserException: unsupported fetch key: ("\m@yahoo.fr\"

Cf the (hopefully) obfuscated message as attachement

Additional Information

Receivers in the "To" header are of the form :
"\"xxx.yyyy@u-p8.fr\"" <p.e@u-p8.fr>

There is no more problem when I change the above to the following (without \"):

"xxx.yyyy@u-p8.fr"

TagsNo tags attached.

Activities

2012-09-20 13:32

 

badsogomail.1 (3,333 bytes)
JMK

JMK

2012-09-28 11:22

reporter   ~0004592

As we encounter others problems with the parser we created a SPGo test instance with ImapDebugEnabled=YES.

I will post here any findings we may have.

2012-09-30 03:34

 

sope.patch (466 bytes)   
diff --git a/sope-mime/NGImap4/NGImap4ResponseParser.m b/sope-mime/NGImap4/NGImap4ResponseParser.m
index 86b3045..1cb5832 100644
--- a/sope-mime/NGImap4/NGImap4ResponseParser.m
+++ b/sope-mime/NGImap4/NGImap4ResponseParser.m
@@ -2548,6 +2548,7 @@ static NSString *_parseUntil(NGImap4ResponseParser *self, char _c) {
     if (c == '\\') {
       _consume(self, 1);
       c = _la(self, 0);
+      if (c == _c) break;
     }
     buf[cnt] = c;
     _consume(self, 1);
sope.patch (466 bytes)   
JMK

JMK

2012-10-01 05:20

reporter   ~0004601

Last edited: 2012-10-01 05:25

I deleted my previous note as it was out of purpose. Also please disregard the 'sope.patch" uploeaded file as it is non-sense...

1 =======
On server headers for the culprit mail is the following:
"ch >> \"ch.x\"" <ch.x@univ-xxx.fr>

2 =======
With Imap deugging enabled SOGo log shows that response to the fetch command is :
("ch >> \ch.x\" NIL "ch.x" "univ-xxx.fr")

3 ========
So it seems

3.1) that our imap server translates a legit SMTP quoted string ("ch >> \"ch.x\"") in a strange one ("ch >> \ch.x\").

3.2) That SOGo is unable to parse the response string "ch >> \ch.x\"

However "ch >> \ch.x\" seems a legit quoted string to me as the double backslashes should translate to a single one ("\" ---> "\")

ludovic

ludovic

2012-11-20 12:18

administrator   ~0004939

That mail works for me when I test it using Cyrus IMAP Server.

What IMAP server (and version) are you using?

ludovic

ludovic

2013-08-09 15:49

administrator   ~0005867

No feedback provided in almost a year, closing.

Issue History

Date Modified Username Field Change
2012-09-20 13:32 JMK New Issue
2012-09-20 13:32 JMK File Added: badsogomail.1
2012-09-28 11:22 JMK Note Added: 0004592
2012-09-30 03:34 JMK File Added: sope.patch
2012-10-01 05:20 JMK Note Added: 0004601
2012-10-01 05:22 JMK Note Edited: 0004601
2012-10-01 05:25 JMK Note Edited: 0004601
2012-11-20 12:18 ludovic Note Added: 0004939
2013-08-09 15:49 ludovic Note Added: 0005867
2013-08-09 15:49 ludovic Status new => closed
2013-08-09 15:49 ludovic Resolution open => suspended