View Issue Details

IDProjectCategoryView StatusLast Update
0000194SOGoWeb Calendarpublic2009-10-26 14:23
Reportertolivier Assigned Toludovic  
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Versionnightly v2 
Fixed in Version1.1.0 
Summary0000194: iCalRecurrenceCalculator loop
Description

When i create a reccuring event in the web calendar, i can't modify events without make a loop in sogod.

Sogo 1.0.4 crash too.

Additional Information

Oct 26 10:03:51 sogod [18814]: [ERROR] <0x0x2095e0[iCalRecurrenceCalculator]> unsupported rrule frequency: <0x9cc73c8[iCalRecurrenceRule]:RRULE

2 values: {
INTERVAL=1
COUNT=5
}>
Oct 26 10:03:51 sogod [18814]: [ERROR] <0x0x2095e0[iCalRecurrenceCalculator]> unsupported rrule frequency: <0x9cc73c8[iCalRecurrenceRule]:RRULE

2 values: {
INTERVAL=1
COUNT=5
}>
Oct 26 10:03:51 sogod [18814]: [ERROR] <0x0x2095e0[iCalRecurrenceCalculator]> unsupported rrule frequency: <0x9cc73c8[iCalRecurrenceRule]:RRULE

2 values: {
INTERVAL=1
COUNT=5
}>
Oct 26 10:03:51 sogod [18814]: [ERROR] <0x0x2095e0[iCalRecurrenceCalculator]> unsupported rrule frequency: <0x9cc73c8[iCalRecurrenceRule]:RRULE

2 values: {
INTERVAL=1
COUNT=5
}>

TagsNo tags attached.

Activities

ludovic

ludovic

2009-10-26 07:22

administrator   ~0000257

How was the rule created? What was specified?

tolivier

tolivier

2009-10-26 09:35

reporter   ~0000258

create an event in web calendar, choose Repeat->Custom, Daily+Every Weekday on 5 days.

Now, edit ALL appointements and shift one hour.

sogod repeat error iCalRecurrenceCalculator in the log.

ludovic

ludovic

2009-10-26 13:11

administrator   ~0000259

It works for me on the latest version.

Please try with the latest nightly - which should become 1.1.0 tomorrow.

2009-10-26 13:42

 

event.jpg (122,455 bytes)   
event.jpg (122,455 bytes)   

2009-10-26 13:42

 

repeat.jpg (66,809 bytes)   
repeat.jpg (66,809 bytes)   
ludovic

ludovic

2009-10-26 13:43

administrator   ~0000260

Nevermind, I can reproduce it.

tolivier

tolivier

2009-10-26 13:49

reporter   ~0000261

1) Event.jpg

2) Repeat.jpg

3) Modify one by "all ocurrences" start the event at 7am

ludovic

ludovic

2009-10-26 14:23

administrator   ~0000262

Fixed by http://mtn.inverse.ca/revision/diff/87f8dab4d95e1de1c7c969e371770ac2d74b83b1/with/c7ad331417d6c2767578747a293dae8820497511

Issue History

Date Modified Username Field Change
2009-10-26 05:12 tolivier New Issue
2009-10-26 07:22 ludovic Note Added: 0000257
2009-10-26 09:35 tolivier Note Added: 0000258
2009-10-26 13:11 ludovic Note Added: 0000259
2009-10-26 13:42 tolivier File Added: event.jpg
2009-10-26 13:42 tolivier File Added: repeat.jpg
2009-10-26 13:43 ludovic Note Added: 0000260
2009-10-26 13:49 tolivier Note Added: 0000261
2009-10-26 14:23 ludovic Note Added: 0000262
2009-10-26 14:23 ludovic Status new => resolved
2009-10-26 14:23 ludovic Fixed in Version => 1.1.0
2009-10-26 14:23 ludovic Resolution open => fixed
2009-10-26 14:23 ludovic Assigned To => ludovic