View Issue Details

IDProjectCategoryView StatusLast Update
0001863SOGoPackaging (Debian)public2012-07-20 15:42
Reportercitral Assigned Tojraby 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.16 
Target Version1.3.17Fixed in Version1.3.17 
Summary0001863: undefined symbol: curl_global_init
Description

When trying to import a web-calendar via the web-interface, after importing the .ics URL, I get in sogo.log:

/usr/sbin/sogod: symbol lookup error: /usr/lib/GNUstep/SOGo/Appointments.SOGo/./ Appointments: undefined symbol: curl_global_init

I tried installing:
libcurl4-openssl-dev
libcurl4-gnutls-dev

But that would not help. Probably something with how the Debian packages are compiled?

Additional Information

Ubuntu 12.04.

TagsNo tags attached.

Activities

jraby

jraby

2012-07-18 16:37

viewer   ~0004174

Should be fixed with this commit: http://mtn.inverse.ca/revision/info/8ce46d6fa7b1d1a9d12069cee3ba796d99d668d2

The problem was caused by a linking problem on recent ubuntu releases (post 11.04), libcurl was simply not linked in.

The fix will be available with the next release.

jraby

jraby

2012-07-19 09:54

viewer   ~0004177

i'm marking this as fixed since the test case I wrote for it passed on ubuntu 12.04 with the latest nightly builds.

Issue History

Date Modified Username Field Change
2012-07-04 05:28 citral New Issue
2012-07-05 08:25 francis Target Version => 1.3.17
2012-07-13 13:56 ludovic Status new => assigned
2012-07-13 13:56 ludovic Assigned To => jraby
2012-07-18 16:37 jraby Note Added: 0004174
2012-07-19 09:54 jraby Note Added: 0004177
2012-07-19 09:54 jraby Status assigned => resolved
2012-07-19 09:54 jraby Resolution open => fixed
2012-07-20 15:42 francis Fixed in Version => 1.3.17