View Issue Details

IDProjectCategoryView StatusLast Update
0001825SOGoWeb Preferencespublic2012-07-25 11:40
Reporterpaul8080 Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.15a 
Target Version1.3.17Fixed in Version1.3.17 
Summary0001825: Vacation record is put as the first one in SIEVE script
Description

When enabling vacation record, it is put as the first record in sieve script file for user. That means it prepends all other filters, including spam filter. That makes system answer absolutely all mail, including SPAM's. And only after that they are put into the spam folder. I'm not sure that it would be better to put it as the last record, but putting it before spam filter definitely makes me rewrite sieve script manually on the server.

TagsNo tags attached.

Activities

toddejohnson

toddejohnson

2012-07-08 22:34

reporter   ~0004106

Is there a temporary workaround for this? This is a big deal! I have filters for my lists and groups that process mail into folders and shouldn't be notified of vacation. Either change the default to make it process last or at least provide an option to choose where the rule is placed. Even if it is site wide.

LSCE IT

LSCE IT

2012-07-17 05:27

reporter   ~0004166

Hello.

I think this problem is even worse than what is being already told. We have the same problem in my lab.

With the vacation filter in first position, you can't even filter Spam beforehand. So we are answering vacation message to spammers. This is especially a problem since some of the Spam is sent by 'spamtraps' of blacklisting societies. Your mail system can end up being considered malconfigured by them, then blacklisted.

So, delivering Spam to user account (tagged or not) + using the SOGo vacation message can lead your mail system to be blacklisted.

The workaround I see right now would be to use the patch found in http://sogo.nu/bugs/view.php?id=1392 (and http://sogo.nu/bugs/view.php?id=1391 as a dependency). I didn't test it right now, but I will do soon and let you know.

francis

francis

2012-07-25 11:32

administrator   ~0004223

Fixed in revision 84638520098e5b0e2cebc6efed95a3c49beac705.

Issue History

Date Modified Username Field Change
2012-05-31 10:21 paul8080 New Issue
2012-07-08 22:34 toddejohnson Note Added: 0004106
2012-07-17 05:27 LSCE IT Note Added: 0004166
2012-07-25 11:32 francis Note Added: 0004223
2012-07-25 11:32 francis Status new => resolved
2012-07-25 11:32 francis Fixed in Version => 1.3.17
2012-07-25 11:32 francis Resolution open => fixed
2012-07-25 11:32 francis Assigned To => francis
2012-07-25 11:40 francis Target Version => 1.3.17