View Issue Details

IDProjectCategoryView StatusLast Update
0001797SOGoWeb Mailpublic2012-05-29 10:31
Reporterwhroberts Assigned Tofrancis  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.14 
Target Version1.3.16Fixed in Version1.3.16 
Summary0001797: Web mail handling of empty Subject
Description

It is not possible to send an email without a Subject.

Perhaps the Thunderbird behaviour of asking "Are you sure you want to send without a subject?" would be more appropriate than preventing it from happening.

If you read a mail with an empty subject, the subject is shown as "Untitled" which is not true.

If you reply to such an email, the subject is pre-filled as "Re: (nil)" which is not true either.

TagsNo tags attached.

Activities

Christian Mack

Christian Mack

2012-05-10 08:33

developer   ~0003879

A) Each email should have a subject.
So in my opinion not sending without a subject is correct behaviour.
At least it is impolite to write none, as the receiver has to open the email and read it in order to see if it is anything she wants to read.

B) What shall it display, when there is no subject?
"None", "Empty", "No subject given"?

C) Yes this really is a bug. it should either reply with
Re: Untitled
or with
Re:

whroberts

whroberts

2012-05-11 00:15

reporter   ~0003885

A) I disagree. It may be impolite to send a message without a subject but it is not the job of a mail client to force the inclusion of a subject. As far as I can tell from limited testing, the SOGo web mail client is unique in doing this. Thunderbird, Mac Mail, GMail, pine, mailx, squirrelmail all allow messages without a subject. Some of these clients ask "Are you sure you want an empty Subject?" but some don't. Surely the internet is about the freedom to do stuff like send emails without a subject :-)

B) It should display nothing - like Thunderbird for example. It should definitely not alter the content of the subject header because this is misleading. If the content is null, that's what should be shown.

C) I agree. I think it should be "Re:" (without the quotes)

Christian Mack

Christian Mack

2012-05-11 03:57

developer   ~0003886

We disagree on A), so let us see what others think, especially Invers.

B) Now I understand you. Yes, it could/should be empty, if you allow empty subjects.

We agree on C).

whroberts

whroberts

2012-05-13 19:57

reporter   ~0003898

RFC 2822 Section 3.6.5 has Subject as an optional "Information field":

http://tools.ietf.org/html/rfc2822

Christian Mack

Christian Mack

2012-05-14 03:05

developer   ~0003899

Good argument.

francis

francis

2012-05-29 10:31

administrator   ~0003979

Fixed in revision 28cde64403e65a1ebeda3a984650fd31d8614f29 and f51ae70ff345179926dfdd4fd5856e968bdfc327.

Issue History

Date Modified Username Field Change
2012-05-09 21:41 whroberts New Issue
2012-05-10 08:33 Christian Mack Note Added: 0003879
2012-05-11 00:15 whroberts Note Added: 0003885
2012-05-11 03:57 Christian Mack Note Added: 0003886
2012-05-13 19:57 whroberts Note Added: 0003898
2012-05-14 03:05 Christian Mack Note Added: 0003899
2012-05-22 13:07 ludovic Target Version => 1.3.16
2012-05-29 10:31 francis Note Added: 0003979
2012-05-29 10:31 francis Status new => resolved
2012-05-29 10:31 francis Fixed in Version => 1.3.16
2012-05-29 10:31 francis Resolution open => fixed
2012-05-29 10:31 francis Assigned To => francis