View Issue Details

IDProjectCategoryView StatusLast Update
0001713SOGo Connectorwith external serverpublic2013-12-17 07:42
Reporterevert Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version10.0 
Fixed in Version24.0.0 
Summary0001713: SOGO CardDAV connector fails with certain contenttypes
Description

Hi!

I'm the author of SabreDAV, and the Sogo connector for Thunderbird is a blessing :)

However, I recently made a change that caused the connector to break.
In previous versions I would send back the following property for every card:

<d:getcontenttype>text/x-vcard</d:getcontenttype>

In a new version, I changed this to:

<d:getcontenttype>text/x-vcard; charset=utf-8</d:getcontenttype>

This was important to ensure that certain clients correctly pick up the vcards as UTF-8 encoded.

SOGO doesn't appear to like this, as I was testing I noticed that the connector doesn't recognize the entries as vcards at all.

TagsNo tags attached.

Activities

Necoro

Necoro

2012-07-13 17:23

reporter   ~0004143

I see this issue here too, when trying to sync with Sogo Connector against the Radicale Server.

The problem seems to be, that the connector does direct string matching (in sync.addressbook.groupdav.js):

if (contType == "text/x-vcard"
|| contType == "text/vcard"
|| contType == "text/x-vlist")

As the RFCs allow attributes after a semicolon, the connector should handle them too.

Sven Giermann

Sven Giermann

2013-12-13 05:15

reporter   ~0006359

Should be fixed in recent versions (verified in 24.0.2), as the code has been replaced by:

    if (itemType.indexOf(&quot;text/x-vcard&quot;) == 0 
          || itemType.indexOf(&quot;text/vcard&quot;) == 0 )

Issue History

Date Modified Username Field Change
2012-03-20 12:07 evert New Issue
2012-07-13 17:23 Necoro Note Added: 0004143
2013-12-13 05:15 Sven Giermann Note Added: 0006359
2013-12-17 07:42 ludovic Status new => closed
2013-12-17 07:42 ludovic Assigned To => ludovic
2013-12-17 07:42 ludovic Resolution open => fixed
2013-12-17 07:42 ludovic Fixed in Version => 24.0.0