View Issue Details

IDProjectCategoryView StatusLast Update
0001702SOGoWeb Mailpublic2012-04-30 16:44
ReporterAltibox Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.12 
Target Version1.3.15Fixed in Version1.3.15 
Summary0001702: selecting same folder for Sent and Drafts causes webui to fail
Description

The webui allows one to right-click on the "Drafts" folder, and select "Use this folder for Sent messages". After this is done, the webui won't let one create any new messages. Clicking "Write" give the error:

An error occurred during object publishing

the requested object could not be found!

Steps To Reproduce

Right-click on the localized "Drafts" folder.
Select "Use this folder for sent messages".
Click "Write" icon.

TagsNo tags attached.

Activities

Christian Mack

Christian Mack

2012-03-16 10:00

developer   ~0003584

You can't write a message, because you don't have any "Drafts" folder defined for SOGo.

Choose another folder, select it and right click on it.
Then choose "Use this folder for" --> "Drafts".

Now you can again write emails.

Altibox

Altibox

2012-03-22 09:53

reporter   ~0003618

Sure, I understand what's happening, but I think it's a bug that you allow this to happen. This is causing problems for our users, so we'd like you to acknowledge this as a bug, and hopefully fix it at some point.

Altibox

Altibox

2012-04-24 09:17

reporter   ~0003809

Hi,

Do you agree that this is a bug? And is there a plan to fix this in a upcoming release?

ludovic

ludovic

2012-04-24 09:19

administrator   ~0003810

We'll have a look at the issue. It should definitively not "crash" for the user, no matter what the user selects - so indeed it is a bug.

ludovic

ludovic

2012-04-30 16:44

administrator   ~0003838

Fixed - see: http://mtn.inverse.ca/revision/diff/4e2b45bb5b0360d8cf107846fa39fb12f6bacf7f/with/7d1f68d661b9fcfd676be1e6d3d6ce6c1fb09df9

Issue History

Date Modified Username Field Change
2012-03-15 15:49 Altibox New Issue
2012-03-16 10:00 Christian Mack Note Added: 0003584
2012-03-22 09:53 Altibox Note Added: 0003618
2012-04-24 09:17 Altibox Note Added: 0003809
2012-04-24 09:19 ludovic Note Added: 0003810
2012-04-24 09:19 ludovic Target Version => 1.3.15
2012-04-30 16:44 ludovic Note Added: 0003838
2012-04-30 16:44 ludovic Status new => resolved
2012-04-30 16:44 ludovic Fixed in Version => 1.3.15
2012-04-30 16:44 ludovic Resolution open => fixed
2012-04-30 16:44 ludovic Assigned To => ludovic
2012-04-30 16:44 ludovic Status resolved => closed