View Issue Details

IDProjectCategoryView StatusLast Update
0001678SOGoBackend Calendarpublic2012-04-18 16:17
ReporterChristian Mack Assigned Toludovic  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.12 
Fixed in Version1.3.15 
Summary0001678: Overbooking of ressources with recurring event possible
Description

User A invites a resource with maximum bookings set to 1 to an event at a given date and time.
User B invites later the same resource with a recurring event at the same time. The event of user B does starts on a date before the event of user A, but one of the recurring parts hits the event of user A.

The event of user B is happily accepted even on the clashing event date without any warning!

Because of this the resource is overbooked on this date.
Both users can look at their events and both will see that this ressource has accepted their event invitation.

Only if user B tries to modify the clashing occurency she will get the "Maximum number of simultaneous bookings (1) reached for ...." Error, which prevents her to store her change.

Expected behaviour:
User B gets the overbooked Error when trying to store the recurring event with a hint on which occurency it happens, preventing the overbooking.

TagsNo tags attached.

Activities

ludovic

ludovic

2012-04-18 08:38

administrator   ~0003762

If user's B event is repetitive, I suggest that we check for one year ahead for conflicts. Otherwise, that might take a significant amount of time to compute all of this.

Christian Mack

Christian Mack

2012-04-18 09:53

developer   ~0003766

Fine with me.
One year ahead should really be enough.

ludovic

ludovic

2012-04-18 16:17

administrator   ~0003768

Fixed.

Issue History

Date Modified Username Field Change
2012-03-13 14:40 Christian Mack New Issue
2012-04-18 08:38 ludovic Note Added: 0003762
2012-04-18 09:53 Christian Mack Note Added: 0003766
2012-04-18 16:17 ludovic Note Added: 0003768
2012-04-18 16:17 ludovic Status new => resolved
2012-04-18 16:17 ludovic Fixed in Version => 1.3.15
2012-04-18 16:17 ludovic Resolution open => fixed
2012-04-18 16:17 ludovic Assigned To => ludovic
2012-04-18 16:17 ludovic Status resolved => closed