View Issue Details

IDProjectCategoryView StatusLast Update
0001644SOGoWeb Calendarpublic2012-04-23 20:37
ReporterChristian Mack Assigned Towsourdeau 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.12 
Fixed in Version1.3.15 
Summary0001644: Imported recurring event from Zimbra is displayed incorrectly
Description

I exported a recurrent event from an old Zimbra account.
Its definition is absolutely valid (see attached ics file).
Then I imported it into a SOGo 1.3.12c test instance.
It is defined as an event on every last friday of each month without end date.
But it will be displayed in SOGo as an event on each friday of each month.

I say is displayed incorrect, because when you check its settings in SOGo, then you see its the defined one (see attached picture).

Steps To Reproduce

Import the attached ics file.
You will see an event on each Friday, which is incorrect.
But if you check the definition for all occurrences, it says event each month on last friday.

Workaround:
Press "Save and Close" without making any change to the recurring event.
It will be displayed correctly.

TagsNo tags attached.

Activities

2012-02-22 09:01

 

WiederholendLetzterFreitag3.ics (2,895 bytes)   
BEGIN:VCALENDAR
PRODID:Zimbra-Calendar-Provider
VERSION:2.0
METHOD:PUBLISH
BEGIN:VTIMEZONE
TZID:Europe/Zurich
BEGIN:STANDARD
DTSTART:19961027T030000
TZOFFSETTO:+0100
TZOFFSETFROM:+0200
RRULE:FREQ=YEARLY;BYMONTH=10;BYDAY=-1SU
END:STANDARD
BEGIN:DAYLIGHT
DTSTART:19810329T020000
TZOFFSETTO:+0200
TZOFFSETFROM:+0100
RRULE:FREQ=YEARLY;BYMONTH=3;BYDAY=-1SU
END:DAYLIGHT
END:VTIMEZONE
BEGIN:VTIMEZONE
TZID:(GMT+02.00) Harare / Pretoria
BEGIN:STANDARD
DTSTART:19710101T000000
TZOFFSETTO:+0200
TZOFFSETFROM:+0200
END:STANDARD
END:VTIMEZONE
BEGIN:VTIMEZONE
TZID:Westeuropäische Normalzeit
BEGIN:STANDARD
DTSTART:19710101T030000
TZOFFSETTO:+0100
TZOFFSETFROM:+0200
RRULE:FREQ=YEARLY;INTERVAL=1;BYMONTH=10;BYDAY=-1SU;WKST=MO
END:STANDARD
BEGIN:DAYLIGHT
DTSTART:19710101T020000
TZOFFSETTO:+0200
TZOFFSETFROM:+0100
RRULE:FREQ=YEARLY;INTERVAL=1;BYMONTH=3;BYDAY=-1SU;WKST=MO
END:DAYLIGHT
END:VTIMEZONE
BEGIN:VTIMEZONE
TZID:Europe/Berlin
BEGIN:STANDARD
DTSTART:19701025T030000
TZOFFSETTO:+0100
TZOFFSETFROM:+0200
RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=-1SU;BYMONTH=10
END:STANDARD
BEGIN:DAYLIGHT
DTSTART:19700329T020000
TZOFFSETTO:+0200
TZOFFSETFROM:+0100
RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=-1SU;BYMONTH=3
END:DAYLIGHT
END:VTIMEZONE
BEGIN:VTIMEZONE
TZID:Europe/Paris
BEGIN:STANDARD
DTSTART:19701025T030000
TZOFFSETTO:+0100
TZOFFSETFROM:+0200
RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=-1SU;BYMONTH=10
END:STANDARD
BEGIN:DAYLIGHT
DTSTART:19700329T020000
TZOFFSETTO:+0200
TZOFFSETFROM:+0100
RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=-1SU;BYMONTH=3
END:DAYLIGHT
END:VTIMEZONE
BEGIN:VTIMEZONE
TZID:GMT+01.00/+02.00
BEGIN:STANDARD
DTSTART:19710101T030000
TZOFFSETTO:+0100
TZOFFSETFROM:+0200
RRULE:FREQ=YEARLY;INTERVAL=1;BYMONTH=10;BYDAY=-1SU;WKST=MO
END:STANDARD
BEGIN:DAYLIGHT
DTSTART:19710101T020000
TZOFFSETTO:+0200
TZOFFSETFROM:+0100
RRULE:FREQ=YEARLY;INTERVAL=1;BYMONTH=3;BYDAY=-1SU;WKST=MO
END:DAYLIGHT
END:VTIMEZONE
BEGIN:VTIMEZONE
TZID:(GMT+01.00) Amsterdam / Berlin / Bern / Rome / Stockholm / Vienna
BEGIN:STANDARD
DTSTART:19710101T030000
TZOFFSETTO:+0100
TZOFFSETFROM:+0200
RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=-1SU;BYMONTH=10
END:STANDARD
BEGIN:DAYLIGHT
DTSTART:19710101T020000
TZOFFSETTO:+0200
TZOFFSETFROM:+0100
RRULE:FREQ=YEARLY;INTERVAL=1;BYDAY=-1SU;BYMONTH=3
END:DAYLIGHT
END:VTIMEZONE
BEGIN:VEVENT
UID:ac880d21-6f13-41f7-ba63-bb9b5bc2bc4a
RRULE:FREQ=MONTHLY;BYDAY=FR;BYSETPOS=-1
SUMMARY:Recurring test event on last Friday in each month
LOCATION:B10
X-MOZ-GENERATION:3
ORGANIZER;CN=Christian Mack:mailto:christian.mack@uni-konstanz.de
DTSTART;TZID="Europe/Berlin":20110930T100000
DTEND;TZID="Europe/Berlin":20110930T110000
STATUS:CONFIRMED
CLASS:PUBLIC
X-MICROSOFT-CDO-INTENDEDSTATUS:BUSY
TRANSP:OPAQUE
X-MICROSOFT-DISALLOW-COUNTER:TRUE
DTSTAMP:20120215T084715Z
SEQUENCE:2
END:VEVENT
END:VCALENDAR

2012-02-22 09:05

 

ImportedRecurringEvent.png (124,522 bytes)   
ImportedRecurringEvent.png (124,522 bytes)   
francis

francis

2012-03-01 16:03

administrator   ~0003515

The "SETBYPOS" rule is not yet supported. To define "last Friday of the month", we use the rule "BYDAY=-FR".

wsourdeau

wsourdeau

2012-04-23 20:37

viewer   ~0003807

This has now been implemented.

Issue History

Date Modified Username Field Change
2012-02-22 09:01 Christian Mack New Issue
2012-02-22 09:01 Christian Mack File Added: WiederholendLetzterFreitag3.ics
2012-02-22 09:05 Christian Mack File Added: ImportedRecurringEvent.png
2012-03-01 16:03 francis Note Added: 0003515
2012-04-23 20:37 wsourdeau Note Added: 0003807
2012-04-23 20:37 wsourdeau Status new => resolved
2012-04-23 20:37 wsourdeau Fixed in Version => 1.3.15
2012-04-23 20:37 wsourdeau Resolution open => fixed
2012-04-23 20:37 wsourdeau Assigned To => wsourdeau