View Issue Details

IDProjectCategoryView StatusLast Update
0001638SOGoBackend Mailpublic2012-05-31 11:51
ReporterjrabyAssigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Versionnightly v2 
Target Version1.3.16Fixed in Version1.3.16 
Summary0001638: SIGABRT when clicking 'sharing' on a non existent IMAP folder
Description

Trying to open the 'sharing' properties on a non-existent IMAP folder will terminate the SOGo child like this:

Feb 16 10:24:04 sogod [26026]: |SOGo| starting method 'GET' on uri '/SOGo/so/username/Mail/0/folderTrash/acls'
2012-02-16 10:24:04.849 sogod[26026] allocated classes:
6 GSCBufferString
-1 GSCInlineString
4 WOCookie

2012-02-16 10:24:04.941 sogod[26026] WARNING(-[NSNull(misc) count]): called NSNull -count (returns 0) !!!
EXCEPTION: <NSException: 0x2f7a4d0> NAME:NSInvalidArgumentException REASON:NSException(instance) does not recognize allKeys INFO:(null)
Feb 16 10:24:05 sogod [25999]: <0x0x208dc70[WOWatchDogChild]> child 26026 exited
Feb 16 10:24:05 sogod [25999]: <0x0x208dc70[WOWatchDogChild]> (terminated due to signal 6)
Feb 16 10:24:05 sogod [25999]: <0x0x20d4e80[WOWatchDog]> child spawned with pid 24212
Feb 16 10:24:05 sogod [26027]: |SOGo| starting method 'GET' on uri '/SOGo/so/username/Mail/0/folderTrash/acls'
2012-02-16 10:24:05.204 sogod[26027] allocated classes:
2 GSCBufferString
-4 GSCInlineString
4 WOCookie

2012-02-16 10:24:05.406 sogod[26027] WARNING(-[NSNull(misc) count]): called NSNull -count (returns 0) !!!
EXCEPTION: <NSException: 0x39ebec0> NAME:NSInvalidArgumentException REASON:NSException(instance) does not recognize allKeys INFO:(null)
Feb 16 10:24:05 sogod [25999]: <0x0x1ecc5d0[WOWatchDogChild]> child 26027 exited
Feb 16 10:24:05 sogod [25999]: <0x0x1ecc5d0[WOWatchDogChild]> (terminated due to signal 6)

This situation should not happen with regular imap folders, but can happen with the 4 'default' folders shown in SOGo (Inbox, Sent, Drafts and Trash).

TagsNo tags attached.

Issue History

Date Modified Username Field Change
2012-02-16 10:34 jraby New Issue
2012-05-22 16:08 ludovic Target Version => 1.3.16
2012-05-31 11:51 ludovic Note Added: 0003989
2012-05-31 11:51 ludovic Status new => resolved
2012-05-31 11:51 ludovic Fixed in Version => 1.3.16
2012-05-31 11:51 ludovic Resolution open => fixed
2012-05-31 11:51 ludovic Assigned To => ludovic
2012-05-31 11:51 ludovic Status resolved => closed