View Issue Details

IDProjectCategoryView StatusLast Update
0000163SOGoBackend Calendarpublic2009-10-13 17:16
Reporterwimmer Assigned Toludovic  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Fixed in Version1.1.0 
Summary0000163: Transfer of time zone within Funambol synchronization
Description

I discovered problem with transfer of time zone within Funambol synchronization.

case 1)

  • I have no saved Preferences in SOGo WebGUI, I see Europe/Prague zone in
    Preferences window (that's correct default setting from SOGoServerTimeZone
    global parameter, it is CEST zone)
  • I create new Event in SOGo WebGUI (started 12:00 CEST)
  • I synchronize my PDA (I'm using funambol client and SOGo Funabol connector),
    Event is transmited, but it starts on 10:00 on PDA calednar
  • when I create other Event in PDA calendar, it is transmited to SOGo
    correctly with right time

case 2)

  • I save my Preferences in SOGo WebGUI
  • I create new Event in SOGo WebGUI
  • I synchronize my PDA and start and end time of this transmited Event are
    correct in PDA calendar

So it looks like SOGo doesn't use correct TZ within synchronization when
user hasn't saved his Preferences. I think SOGo would use default
SOGoServerTimeZone global parameter in this case.

Thanks

TagsNo tags attached.

Activities

ludovic

ludovic

2009-10-09 13:22

administrator   ~0000149

This is the normal behavior.

Funambol can NOT access the values in the .GNUstepDefaults file.

ludovic

ludovic

2009-10-09 13:23

administrator   ~0000150

This is also documented in the connector's README file:

3- If you sync and on your device, events (or start/due dates for
tasks) are offset, this means your devices is NOT UTC-capable
and that you MUST set your time zone from SOGo Web's interface.

wimmer

wimmer

2009-10-09 18:03

reporter   ~0000155

I'm sorry for reopening.
I'm understanding both notes now and I agree with them.
On the other side I'm affraid many people will have same problem,
because they will not have their Preferences saved.
So I have one suggestion - If I understand better how Preferences work now

  • there are few preferences options, which are saved into users' preferences
    by his first login into SOGo.
    When this is not my mistake, SOGo WebGUI could save default TimeZone value
    from .GNUstepDefaults file into users' preferences by his first login too and
    all remaining things could work greatly then without changes...
ludovic

ludovic

2009-10-13 17:16

administrator   ~0000159

Fixed in http://mtn.inverse.ca/revision/diff/4437a82e041d016710ea3a45d8b7cf5b6341afff/with/0746b51101ad96419ffd4e8f557f967f13b70a60

Issue History

Date Modified Username Field Change
2009-10-06 07:17 wimmer New Issue
2009-10-09 13:22 ludovic Note Added: 0000149
2009-10-09 13:23 ludovic Note Added: 0000150
2009-10-09 13:23 ludovic Status new => closed
2009-10-09 13:23 ludovic Resolution open => won't fix
2009-10-09 18:03 wimmer Note Added: 0000155
2009-10-09 18:03 wimmer Status closed => feedback
2009-10-09 18:03 wimmer Resolution won't fix => reopened
2009-10-13 17:16 ludovic Note Added: 0000159
2009-10-13 17:16 ludovic Status feedback => resolved
2009-10-13 17:16 ludovic Fixed in Version => 1.1.0
2009-10-13 17:16 ludovic Resolution reopened => fixed
2009-10-13 17:16 ludovic Assigned To => ludovic