View Issue Details

IDProjectCategoryView StatusLast Update
0001610SOGoSOPEpublic2012-03-22 13:04
ReporterwsourdeauAssigned Toludovic  
PrioritynormalSeveritymajorReproducibilityrandom
Status resolvedResolutionfixed 
Fixed in Version1.3.14 
Summary0001610: UnixSignalHandler: remove class
Description

This class module is unsafe as it enables memory allocation or deallocation from signal handlers, causing processes to hang sometimes. It either should be fixed or should be removed (especially since it's quite complex).

TagsNo tags attached.

Relationships

related to 0000491 closed sig* API is deprecated 
related to 0000944 closed bring UnixSignalHandler.m up-to-date 

Issue History

Date Modified Username Field Change
2012-01-31 09:44 wsourdeau New Issue
2012-03-21 16:00 ludovic Relationship added child of 0000944
2012-03-21 16:00 ludovic Relationship added child of 0000491
2012-03-21 16:01 ludovic Relationship deleted child of 0000491
2012-03-21 16:01 ludovic Relationship added related to 0000491
2012-03-21 16:01 ludovic Relationship deleted child of 0000944
2012-03-21 16:01 ludovic Relationship added related to 0000944
2012-03-22 13:04 ludovic Note Added: 0003621
2012-03-22 13:04 ludovic Status new => resolved
2012-03-22 13:04 ludovic Fixed in Version => 1.3.14
2012-03-22 13:04 ludovic Resolution open => fixed
2012-03-22 13:04 ludovic Assigned To => ludovic