View Issue Details

IDProjectCategoryView StatusLast Update
0001565SOGoWeb Mailpublic2012-01-20 07:30
Reporterwimmer Assigned Tofrancis  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.3.11 
Target Version1.3.12Fixed in Version1.3.12 
Summary0001565: Strange parsing of addresses
Description

When user composes new e-mail message and writes addresses of recipients as:
john@a.com, ed@b.com, <peter@c.com>
SOGo translates them to the form:
"john@a.com, ed@b.com," <peter@c.com>
and sends that message to <peter@c.com> only.

I think user uses correct way of addressing, but SOGo doesn't send his message to all recipients - and nobody knows about it.

When user uses ';' character as delimiter in place of ',' , there is not that problem.

Please look to 0001475, it is another opened ugly parsing issue too.

TagsNo tags attached.

Activities

mra

mra

2012-01-04 03:23

reporter   ~0003253

This seems to be the same error as mentioned in 0001340, isn't it?

francis

francis

2012-01-20 07:30

administrator   ~0003297

Fixed in revision 632eeeeca5246bb30406e393c6ada60e6edd6259.

Issue History

Date Modified Username Field Change
2012-01-03 15:46 wimmer New Issue
2012-01-04 03:23 mra Note Added: 0003253
2012-01-05 09:45 francis Target Version => 1.3.12
2012-01-20 07:30 francis Note Added: 0003297
2012-01-20 07:30 francis Status new => resolved
2012-01-20 07:30 francis Fixed in Version => 1.3.12
2012-01-20 07:30 francis Resolution open => fixed
2012-01-20 07:30 francis Assigned To => francis