View Issue Details

IDProjectCategoryView StatusLast Update
0001530SOGoBackend Mailpublic2017-01-20 11:30
Reporterjanfrode Assigned Tofrancis  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version1.3.10 
Fixed in Version3.2.6 
Summary0001530: automatically disabling vacation messages without cron job and master user
Description

I think it's quite unfortunate that you require a cron job and a master-user to disable vacation messages. I don't want to have a master user that can read all our users messages. This should be possible to handle completely within sieve:

require ["date", "relational", "vacation"];

if currentdate :value "le" "date" "2011-12-09" {
vacation "I'm out of office this week. I'll be back on Saturday
10th to reply to your e-mails.";
}

Additional Information

Thanks to Stephan Bosch for suggesting this:

http://dovecot.org/list/dovecot/2011-December/062406.html
TagsNo tags attached.

Relationships

has duplicate 0001949 resolvedfrancis Better Sieve management 
has duplicate 0001529 resolvedludovic sieve: auto-activation of vacation message 

Activities

francis

francis

2011-12-08 14:33

administrator   ~0003136

Last edited: 2011-12-08 14:34

The Sieve server needs to support the date extension : http://tools.ietf.org/html/rfc5260

Cyrus doesn't yet support this extension so I suggest to keep the cronjob for the moment.

Eventually, we'll need to start by modifying the Sieve client implementation of SOPE so it decomposes the list of supported extensions.

Ref:
http://lists.andrew.cmu.edu/pipermail/cyrus-devel/2010-December/001685.html
http://www.cyrusimap.org/mediawiki/index.php/Future_Ideas

toddejohnson

toddejohnson

2012-07-08 22:41

reporter   ~0004107

Would it be possible to make this an option for those of us who use dovecot and don't want to add master users? Might be a easier middle ground in the meantime compared to decomposing the list of supported extensions.

alessio

alessio

2012-07-17 03:45

reporter   ~0004165

i agree should be very useful

piethein

piethein

2012-07-18 03:48

reporter   ~0004168

Would be great to get rid of the master user, for now I have limited the use of the master user (and sieve) https://inverse.ca/sogo/lists/arc/users/2012-03/msg00158.html.

niklaas

niklaas

2016-11-18 12:11

reporter   ~0010890

I tried using the vacation feature but realised that date/time restrictions don't work. So it's still necessary to use a cronjob?

francis

francis

2016-11-18 12:32

administrator   ~0010891

Yes.

niklaas

niklaas

2016-11-18 12:38

reporter   ~0010892

Are there plans to implement this soon because Cyrus now supports the extension? See https://cyrusimap.org/imap/rfc-support.html

Related Changesets

sogo: master 3efe0e80

2017-01-20 11:08:24

francis

Details Diff
Add support for date extension of Sieve

Fixes 0001530, 0001949
Affected Issues
0001530, 0001949
mod - NEWS Diff File
mod - SoObjects/SOGo/SOGoSieveManager.m Diff File

sogo: v2 9539b8ce

2017-01-20 11:08:24

francis

Details Diff
Add support for date extension of Sieve

Fixes 0001530, 0001949
Affected Issues
0001530, 0001949
mod - NEWS Diff File
mod - SoObjects/SOGo/SOGoSieveManager.m Diff File

Issue History

Date Modified Username Field Change
2011-12-07 06:52 janfrode New Issue
2011-12-08 14:33 francis Note Added: 0003136
2011-12-08 14:34 francis Note Edited: 0003136
2012-07-08 22:41 toddejohnson Note Added: 0004107
2012-07-17 03:45 alessio Note Added: 0004165
2012-07-18 03:48 piethein Note Added: 0004168
2012-08-21 12:46 ludovic Relationship added has duplicate 0001949
2012-09-20 16:06 ludovic Relationship added has duplicate 0001529
2016-11-18 12:11 niklaas Note Added: 0010890
2016-11-18 12:32 francis Note Added: 0010891
2016-11-18 12:38 niklaas Note Added: 0010892
2017-01-20 11:09 francis Changeset attached => sogo master 3efe0e80
2017-01-20 11:09 francis Assigned To => francis
2017-01-20 11:09 francis Resolution open => fixed
2017-01-20 11:10 francis Status new => resolved
2017-01-20 11:10 francis Fixed in Version => 3.2.6
2017-01-20 11:30 francis Changeset attached => sogo v2 9539b8ce