View Issue Details

IDProjectCategoryView StatusLast Update
0001523SOGoBackend Calendarpublic2011-12-30 08:12
Reportercwright Assigned Towsourdeau 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.3.10 
Fixed in Version1.3.11 
Summary0001523: New event description fields truncated after first line
Description

After upgrading to 1.3.10, we're seeing the description fields of events with multiple lines truncated to just the first line after the event is saved.

Issue occurs with events and tasks saved from the Web interface or Lightning. Also able to reproduce this on the demo site.

Additional Information

Attached screenshots (from the demo site).

create_desc.png = creation of an event with multiple lines in the description field.

view_desc.png = viewing the event after it has been saved, with only the first line of the description present.

TagsNo tags attached.

Relationships

child of 0001182 resolvedwsourdeau Contacts with notes: only first line shows in web interface 

Activities

2011-12-02 18:36

 

create_desc.png (42,045 bytes)   
create_desc.png (42,045 bytes)   

2011-12-02 18:36

 

view_desc.png (57,966 bytes)   
view_desc.png (57,966 bytes)   
wsourdeau

wsourdeau

2011-12-06 13:46

viewer   ~0003123

Does this still occur with the nigthlies on your site? With the current code, I am unable to reproduce that issue. Also, what kind of SQL backend are you using: MySQL or PostgreSQL ?

cwright

cwright

2011-12-06 14:02

reporter   ~0003124

Hi Wolfgang. Just started testing with nightlies on demo box. Still seeing the truncation, after the first carriage return.

Using:
PostgreSQL 8.4
sogo-2.0_20111206-1.el5

Thank you!

wsourdeau

wsourdeau

2011-12-06 15:30

viewer   ~0003127

That was a bug in the SOPE PG adaptor. Fixed in 747d54047e7fe372edb0003f61bcce0af406b5fc.

ludovic

ludovic

2011-12-30 08:12

administrator   ~0003213

This now works as expected.

Issue History

Date Modified Username Field Change
2011-12-02 18:36 cwright New Issue
2011-12-02 18:36 cwright File Added: create_desc.png
2011-12-02 18:36 cwright File Added: view_desc.png
2011-12-06 13:46 wsourdeau Note Added: 0003123
2011-12-06 13:46 wsourdeau Status new => feedback
2011-12-06 14:02 cwright Note Added: 0003124
2011-12-06 15:30 wsourdeau Note Added: 0003127
2011-12-06 15:30 wsourdeau Status feedback => resolved
2011-12-06 15:30 wsourdeau Fixed in Version => 1.3.11
2011-12-06 15:30 wsourdeau Resolution open => fixed
2011-12-06 15:30 wsourdeau Assigned To => wsourdeau
2011-12-12 12:17 francis Relationship added child of 0001182
2011-12-30 08:12 ludovic Note Added: 0003213
2011-12-30 08:12 ludovic Status resolved => closed