View Issue Details

IDProjectCategoryView StatusLast Update
0001521SOGoWeb Mailpublic2015-10-23 15:12
Reporteraschild Assigned Toludovic  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.9 
Target Version3.0.0Fixed in Version3.0.0 
Summary0001521: Webbrowser freeze with large mail folders
Description

When a mail folder has many emails in it, the webbrowser can freeze because in background all mail headers are retrieved by the UI.

We had this night the case where a server did go crazy and did fill one mailbox with 500k mail messages.

When we open that mail folder in sogo web ui, then the folder is displayed and the first headers are shown correctly and we can start working with it.

But then a few seconds later the web browser (Firefox 8.x) gives a warning about unresponsive script and then completely freezes.

Additional Information

It looks like the js ui does retrieve all mail headers in background.
When there is a huge amount of mails in a folder, this can lead to all sorts of problems, mailny resulting in a unresponsive browser.

Sogo should use a paging system to only retrieve partial message lists as needed.

(Thunderbird 3.1.x has a similar problem)

TagsNo tags attached.

Relationships

has duplicate 0002835 resolvedludovic Webbrowser hangs with large mail folders 

Activities

ludovic

ludovic

2015-10-23 15:12

administrator   ~0009040

This has been fixed in v3. We now use the virtual scroller in Angular Material. beta3 has that code.

When you have a very large number of mailboxes, it's still slow in v3, but not when you have a gazillion of messages. We are working on the large number of mailboxes bug.

Issue History

Date Modified Username Field Change
2011-12-02 02:44 aschild New Issue
2014-07-07 04:36 Christian Mack Relationship added has duplicate 0002835
2015-03-18 15:07 ludovic Severity major => feature
2015-03-18 15:07 ludovic Target Version => 3.0.0
2015-10-23 15:12 ludovic Note Added: 0009040
2015-10-23 15:12 ludovic Status new => closed
2015-10-23 15:12 ludovic Assigned To => ludovic
2015-10-23 15:12 ludovic Resolution open => fixed
2015-10-23 15:12 ludovic Fixed in Version => 3.0.0